Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Something strange has happened. I can't run some command line executables in Windows anymore.

Steps:

  • Open cmd
  • Run an executable, such as ruby -v or git -h

When I do that, a new command prompt opens, running that command (I think, it's too fast to see), and instantly closes again.

I've managed to print screen the new command prompt, and it shows that it's running inside this path:
C:\Documents and Settings\Administrator\Local Settings\Temp\3582-490

Inside this folder, is the executable I'm tring to run.
If I run ruby, then ruby.exe is in there.
If I run git, then git.exe is in there. And it's always emptying the folder in between, so there is always just one .exe file

share|improve this question

migrated from programmers.stackexchange.com Nov 13 '11 at 16:02

This question came from our site for professional programmers interested in conceptual questions about software development.

    
It's only some console programs that do this? Not all of them? –  cHao Nov 13 '11 at 21:26
2  
Anti Virus time! –  Robert French Nov 13 '11 at 21:53
    
Wow, you are actually correct. Haven't had a virus in YEARS :) Thanks. –  Frexuz Nov 15 '11 at 12:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.