Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Xen on my Fedora box. Dom0 image has network connectivity. But when I try to create a DomU, it does not have network connectivity.

I want to be able to run in bridged mode. I have the /etc/xend/xend-config.sxp file accordingly. My config file looks like

kernel = "/boot/vmlinuz-2.6.18-xenU" memory = 64 name = "clientA" vif = ['bridge=xenbr0,mac=12.34.56.78.9A.BC'] root = "/dev/sda1 ro" ramdisk = "/boot/initrd-linux.img" extra = "ro selinux=0.3 initcall_debug" features = 'auto_translated_physmap'

Am I missing something ?

share|improve this question
up vote 0 down vote accepted

It is recommended and also default in Xen 4.1+ to setup the network bridges using the networking scripts in the distro scripts. You would then disable the bridge code in the xend config (in 4.1+ xend is deprecated).

You can follow these instructions for "Red Hat-style bridge configuration (e.g. RHEL, Fedora, CentOS)" http://new-wiki.xen.org/wiki/HostConfiguration/Networking

To troubleshoot in general you can use the brctl tool.

For example,

brctl show
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .