Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just installed a clean copy of XP SP2 using VMware workstation 6.5.2, but the system won't get online.

I can ping google.com just fine from the command line, but it refuses to let me use a browser to access the internet. Any suggestions?

share|improve this question

migrated from serverfault.com Sep 4 '09 at 12:57

This question came from our site for professional system and network administrators.

    
Can you define "get online?" Are you trying to access a particular website through a browser? Trying to connect to a server via SSH? etc. –  Ionise Sep 4 '09 at 5:51
    
u can use bridged ,i had to also assign a static ip etc to vm –  user48614 Feb 2 '11 at 20:53

5 Answers 5

up vote 3 down vote accepted

How do you have your networking configured in VMware (Host-only, NAT, Bridged)? How's your firewall configured on the machine VMware is installed on? Do you have other VMs on this machine that are able to access the internet? Do you use any third party internet security suite inside the VM? Can you reach the usual destinations, your router (default gateway), DNS servers, other machines on your network?

Dave

share|improve this answer
    
Check all firewalls, both on the VM and the host machine. Some firewalls will allow all pings through, but will block certain other communications. I had this problem years ago with ZoneAlarm firewall and an older (obviously) version of VMWare. –  Joshua Nurczyk Sep 4 '09 at 14:51
    
I changed from NAT to bridged and it all started working! Thanks! –  kylex Sep 4 '09 at 14:58

OK, if ping google.com works then you're at least sure that:

  1. UDP DNS requests work (to resolve google.com to an IP address)
  2. ICMP packets work (to receive the ping echo replies)

and when those two work, it's quite peculiar than TCP (used by HTTP) doesn't work too. Maybe it's a problem of the browser and not of the network? (configured a proxy or something?)

To exclude the browser from the equation you can try telnetting to port 80, such as:

C:/> telnet google.com 80
GET / HTTP/1.1
Host: google.com
<enter>
<enter>
share|improve this answer
    
and that your routing table is ok. :-) –  Maxwell Sep 4 '09 at 12:13
    
It won't let me telnet to google.com port 80. The connection faiils. –  kylex Sep 4 '09 at 13:35

I had the same problem, and had just removed my Norton Antivirus. An entire morning of trial and error + research revealed that this could be the problem because Norton leaves bits and pieces lying around when you use Windows Add/Remove programs to remove it. I Googled "norton software removal tool", which took me here: http://us.norton.com/support/kb/web_view.jsp?wv_type=public_web&docurl=20080710133834EN&ln=en_US

Downloaded, used the tool, and magically, everything works again!

share|improve this answer

If you still use Kerio personal firewall (like I do), you must ensure to enable the tickbox GATEWAY-MODE (sth. like: config->Network->advanced) otherwise you just will be able to resolve dns/queries and ping but no other traffic (browsing/downloading/etc) will work.

share|improve this answer

Basically you have to understand how NAT works in VMware.

  • A new connection (Connection A) will be created in your hosting system (which don't have Internet access if you are using Windows 7).

  • A network connection (B) is created in the guest machine which connects to the connection in host (A).

The problem is, usually A can't access the Internet and sometimes B's gateway setting is wrong.

So, things you need to do to fix the NAT Internet problem:

  1. Make sure you are connecting A to the Internet. You can do this by sharing your default connection to A
  2. Set B's gateway IP to A's IP address.

It should then work. Alternatively you can simply turn off the firewalls on the host (sometimes this won't work because the ports have changed due to the usage of NAT).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.