Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is a repost of this question at Android SE.

There's an Asus 240 MIMO Wifi access point. There's a laptop running Windows XP that uses that access point no problem for years so far. And there's an Android based HTC Desire S smartphone that has problems. The objective is to make the smartphone access the Internet via the Wifi access point.

I open "wireless networks" configuration pane, "enable" Wifi - it goes through "scanning" and "obtaining IP address" stages, says "connected to TheRightNetworkName". The Wifi symbol is displayed in the bar under the top of the screen. Yet when I try to open any page in a browser if wouldn't do so and claim there were problems accessing that page.

I tried the following (listed in this answer below, thanks to user Matthew Read):

  • rebooted the phone - doesn't help
  • checked MAC filtering on the AP - it is disabled
  • disabled the firewall on the AP - doesn't help
  • tried to change channels - doesn't help, the AP has 13 channels if that matters
  • tried to change to 2.4 GHz - looks like it is already the only option, couldn't find any way to change the range
  • didn't try to switch from WPA that is currently used to WEP because it feels quite scary - I can mess things up
  • tried switching modes - b, g, b/g - doesn't help

Also tried to ping the smarphone IP from the laptop - the ping is okay.

The same smartphone works okay on two other WPA-protected networks okay, the problem is only on that network.

How do I debug and resolve this issue?

share|improve this question

1 Answer 1

So you've happily disabled the firewall on it ok, yet changing from WPA to WEP seems scary?!

Disabling WEP would be one of the first things i would try after disabling MAC filtering... Have you also added the phones MAC into the filters? I don't know the Galaxy S but check there's no proxy settings set...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.