Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every once in a while, my MacBook Air becomes unresponsive when it is sleeping and I open the lid.

It seems to only happen in these circumstances:

  • the MacBook air got into sleep modus because of closing the lid
  • VMware Fusion 4 (4.0.2 build 491587) is running full screen
  • The guest OS has a blank screen screen saver

When opening the lid, the backlight goes on, but the MacBook Air does not react on any key-combinations I tried.

I tried these, but to no avail:

  • press the Touchpad
  • press Control + Command
  • press Control + Command + Enter
  • press Command + Tab

The only thing that works is to press the Power button for 5+ seconds (forcing a hard power off) then reboot.

Two questions:

  • For anyone having seen similar bahviour: what circumstances did you have?
  • Any solution to this apart from first suspending the guest VM?

Please feel free to edit and/or re-tag this question.

share|improve this question
1  
While I don't have an answer yet, I too have been experiencing the same issue: http://superuser.com/questions/355036/macbook-air-reboot-after-wake-when-window‌​s-7-running-in-vm I also tried Parallels, but it's the same situation. Eventually I switched to VMware to save a few bucks, but like you, I am stuck having to remember to sleep the VM before I sleep the MBA. If I happen to forget though, I need to do the hard reset just as you describe. Really wish there was a fix or some better work around –  rfastturnlow Dec 12 '11 at 6:14
    
Thanks; I upvoted your question. Maybe we should merge both questions into one? –  Jeroen Wiert Pluimers Dec 12 '11 at 11:40
1  
Having the same problem. This isn't isolated, and for people answering - please note that it's not about the VM hanging, the HOST OS (OS X) locking. Keyboard is no longer responsive, trackpad is not responsive to touch or click. This is a major F-up in OS X in my opinion, even if VMWare/VirtualBox/Parallels is causing it. –  user157868 Sep 12 '12 at 14:48
    
Thanks for the heads up. –  Jeroen Wiert Pluimers Sep 12 '12 at 15:01
add comment

1 Answer 1

up vote 1 down vote accepted

I had a similar issue. On a MacPro (Dual Quad Core hyperthreaded, 32GB Memory ), OSX Lion Server, I am running Windows 7 in one VM (Fusion 4.1.1) with Visual Studio 2010, SharePoint Foundation 2010, and SQL Server 2008 R2. A Virtual Drive is mapped to another VM, running Windows 2008 Server R2 and SharePoint 2010 Enterprise Server. Virtual Drives are mapped to a Source Code folder (for VS2020 projects), and to the Windows 2008 GAC, required for debugging code on the Windows 2008 SharePoint Server VM using Remote Debugging. Also mounted are three more VMs. SOLR Search engine VM running in UBuntu, LYNC Unified Communications Server running in Windows 2008 Server R2, and Active Directory running in a Windows 2008 Server VM. * The VS2010 Dev VM is running on an 8TB (configured as 6 Raid 5 eSata connected storage device), and two of the VMs are running on the MacPro internal drives (configured as 4 TB Raid 5 an 1TB JBOD).

When the host OSX Lion Server goes into Screen Save mode, even sometimes before but after a few minutes, VMWare Fusion hangs. If you look at the processes in Activity Monitor, it says "VMWare Fusion (not responding)". When you get this, you need to hard-boot the server. Fortunately, VMWare is robust enough that nothing gets corrupt. OSX Server is never a concern. * Note, I posted to a VMWare Community thread before about a Black Screen issue, when I was running OSX Snow Leopard Server and tried to upgrade to Fusion 4.

I tried everything, and nothing worked, until I saw the post in this thread that full screen in 4.1.1 has issues. That connected my thinking with the Black Screen issue I had which isolated the issue to Full Screen view mode as well. I found when dealing with the Black Screen issue that if I unintentionally ended up in Full Screen, or Unity View, I got the Black Screen issue and had to reboot as well. So the ability to keep Full Screen mode a bay through the following config for each VM worked wonders ( FUSION | VIEW | FULL SCREEN MINIBAR | ALWAYS SHOW ). Now I can have Full Screen functionality without the system locking up Fusion.

  • I recall, in the release notes for 4.1.1 that a slight delay is inserted in Full Screen view model, and I wonder if this is causing an event clash, such that VMWare Fusion locks into listening for the Full Screen VMWare menu to slide down but it never happens, so it becomes unresponsive. Irrespective, the workaround above works for me, and finally, after many gruelling hours, I am up on OSX Lion Server and VMware Fusion 4.1.1.

Hope this helps save someone some time and frustration.

share|improve this answer
add comment

protected by Community Dec 10 '12 at 22:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.