Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the following machine configuration:

  • Intel Core 2 Duo E6300
  • 1 x 2048 MBytes memory chip
  • 2 x 1024 MBytes memory chip
  • 1 x Radeon HD 4870
  • Motherboard : Gigabyte 945P-S3
  • Windows 7 RTM 64-bit

In both Windows and the BIOS I have 3.25GB memory available. How can I enable it to support 4GB?

EDIT: I've sort of upgraded the CMOS version, and Windows acknowledges I have 4GB but is only using 3.25GB.

alt text

I guess it is hardware after all?

share|improve this question
add comment

migrated from serverfault.com Sep 4 '09 at 13:24

This question came from our site for professional system and network administrators.

6 Answers

up vote 4 down vote accepted

I'm fighting the same battle right now. Pretty sure we're hosed with the i945 chipset. Granted, I'd love to be proven wrong!

share|improve this answer
1  
Yes, Chris. Same thing, Had a vista 32bit before, upgraded to Win7 64 bit. Disappointing. –  ArielBH Sep 4 '09 at 13:40
1  
Chris, here is another dude with the same problem I believe. ifrankie.com/?p=70 the comments suggest a petition, maybe you can join in. –  ArielBH Sep 4 '09 at 13:51
add comment

Your BIOS needs to support memory hole remapping.

Memory hole is there since all devices must fit in 32-bit address space during boot (since BIOS is not aware whether you will use 32-bit or 64-bit OS later). Remapping takes care to move affected memory to memory area after 32-bit boundary.

I would check whether new BIOS firmware is available if that setting is not in your current BIOS firmware.

share|improve this answer
    
Yes, there is a newer firmware version. Right now I've F2 installed. I will try to update, right? bit.ly/M0Fgv –  ArielBH Sep 4 '09 at 9:25
1  
@ArielBH: yes, update is almost always a good thing. –  Josip Medved Sep 4 '09 at 10:11
1  
Strangest thing. I tried to update the CMOS. I did every step by the book. The cmos failed to load. I had to clear the CMOS. CMOS is up again, and now when I check the version, it indicate the new version, how can it be? –  ArielBH Sep 4 '09 at 13:34
1  
@ArielBH: It is definitely strange. I would try to update it once more just to check whether it updated everything. Most BIOS update routines check whether old BIOS fits ok. –  Josip Medved Sep 4 '09 at 15:54
2  
@josip frankly I feel lucky that I've managed to get the cmos to work again. I think I will not touch it anymore :) –  ArielBH Sep 4 '09 at 21:33
add comment

Josip is correct that the BIOS with memory hole remapping is necessary. As Chris_K tries to say your hardware must also to be able to physically address more than 4GB see KB929605. I believe that the Intel 945 chipset family cannot do this. So, sorry to say your out of luck.

share|improve this answer
add comment

Windows 7 x64 should recognize that RAM with no fiddling required.

If the BIOS doesn't recognize all 4 GB, there's no chance Windows will see it. It's possible that the reason they provide a memory support list is because the board is very choosy.

I would each of your ram sticks individually, to make sure the BIOS sees them correctly.

Now that I'm thinking about it, the SU guys are going to have a lot more experience with this.

share|improve this answer
1  
Josip is probably right - did you find any options related to memory hole remapping in the bios? –  Kara Marfia Sep 4 '09 at 12:54
add comment

It looks like the 945 chip set doesn't support more than 4 GB of address space (and some versions only 2GB). So you end up with the same limitation as Vista 32 bit - you won't be able to use all of 4 GB of your RAM since address space is used for more than just RAM.

From the Intel 945 chip set datasheet page 24:

The (G)MCH supports 32-bit host addressing, decoding up to 4 GB (2 GB for the 82945PL/82945GC/82945GZ) of the processor’s usable memory address space

And of page 205:

Addressing of memory ranges larger than 4 GB (2 GB for 82945GC/82945GZ/82945PL) is not supported

share|improve this answer
add comment

The manual for your motherboard doesn't say it is a requirement, but it does advise using the same size memory modules. It's possible that having 1gb modules being scanned first is preventing it from detecting the larger 2gb module.

I would try swapping which bank the modules are in ( 1x2gb <-> 2x1gb ) and see if that helps, failing that I think you just need to get two 1gb modules to replace your existing 2gb module.

Of course, the up-side of the latter would be that you'd re-enable dual-channel and get faster memory use of the system.

share|improve this answer
    
Yes, I had those 2*1GB chips. My last visit to Redmond, USA i've bought 2 chips of 2GB. As it happens one of them was faulty, so I got stuck with only one (and I live abroad USA). –  ArielBH Sep 4 '09 at 13:43
    
Yeah--I would never mix memory chips like that. It's not the culprit but it's just asking for trouble. –  Loren Pechtel Sep 4 '09 at 15:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.