Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I found a file called Thumbs.db:encryptable on my image folder, and I can't delete it. I've tried reboot my PC, but it doesn't work.

When I try to delete a folder that contains this file, this message appears:

del Thumbs.db* /s /f

D:\My Documents\My Pictures\My Photos Christmas\Thumbs.db:encryptable
The system can not find the file specified.

share|improve this question

6 Answers 6

Ads Spy is a tool used to list, view or delete Alternate Data Streams (ADS) on Windows 2000/XP with NTFS file systems. ADS is a way of storing meta-information for files without actually storing the information in the file it belongs to, carried over from early MacOS compatibility from Windows NT4. Recently browser hijackers began using this technique to store hidden information on the system, and even store trojan executable files in ADS streams of random files on the system. Use with caution.

Usage Instructions:

Download this program and run it. If you would like to just scan the Windows directory, then you can click on the Scan System button and it will scan your Windows directory for Alternate Data Stream files. You then have the option to select the ones you would like to delete, and press the Remove button. If you would like to scan the entire hard drive for ADS files, uncheck the Quick Check checkbox.

For more information on Alternate Data Streams you can read this tutorial:

Windows Alternate Data Streams

share|improve this answer

Unlocker is an Explorer extension that allows you to simply right-click on a file or folder to get rid of error messages associated with moving or deleting it.

Read more: Unlocker - Free software downloads and software reviews - CNET Download.com

share|improve this answer

I just ran CHKDSK and it removed them as the filename is invalid...

share|improve this answer
    
Best way for me and does not required 3rd party tool. –  mot Mar 3 at 11:02

Quote, and use the \\?\ prefix on the file name.

For example:

del "\\?\D:\My Documents\My Pictures\My Photos Christmas\Thumbs.db:encryptable"

As one of the other answers mentioned, the colon is used to designate an alternate data stream. Somehow, the encryptable ADS got saved as it's own file rather than an ADS attached to Thumbs.db.

The colon isn't a legal character in a file name, but using the \\?\ prefix tells the file sytem, "No, really. I mean a file with a colon in the name." It works on extra long file names, and trailing spaces, and other weird file names.

share|improve this answer

I was fighting this for way too long for such a simple operation, and found a great fix. Basically there was a resource fork on my file at H:\pictures\thumbs.db. I tried adding jpegs to get the filesize to change and it did, but I still could not delete the file. So what I did instead was use this utility called ADSCheck from SourceForge: http://sourceforge.net/projects/adscheck/

It's a command-line utility, so open up a command prompt, and then run in my case (I copied adscheck.exe to H:):

adscheck.exe H:\pictures /d

The /d switch will delete all alternate data streams in the path, which it did.

At that point for some reason I still couldn't delete the Thumbs.db file, so I said to heck with it, and just used edit at the command-line:

edit H:\pictures\thumbs.db

I then typed in some garbage text, and saved the file out. At that point I confirmed that I could manipulate it by renaming it:

move H:\pictures\Thumbs.db H:\pictures\iwashere.txt

Then I did:

del *.*
cd H:
rmdir pictures

And it's all cleaned up.

share|improve this answer

The person in the following link was having your problem. He tried several solutions to try to get rid of it - failed each and ultimately resulted in booting into Linux to mount the NTFS partition and delete the file:

http://aparateys.blogspot.com/2008/04/troubles-with-file-thumbsdbencryptable.html

Maybe you'll be able to take the previous steps before having to boot into Linux. The first one seems pretty self explanatory - disable thumbnail caching and then reboot the computer and see if the file goes away. Then progress down the chain and see if any of them work for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.