Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 7 on a MacBook Pro connected to a Kensington Universal Multi-Display adapter. When I have a WPF application on the monitor it doesn't display correctly. WPF applications will not repaint themselves except for the title bar. When I drag the app over there and release the drag the application looks fine, but I can't interact with it because it won't repaint itself. If I make another window come on top of it, I have to drag the WPF application to a different monitor to get it to repaint.

How can I fix this?

share|improve this question
    
Have you tried updating your DisplayLink driver (from Displaylink.com) to the latest? –  Ƭᴇcʜιᴇ007 Nov 15 '11 at 21:36
    
This is a driver issue. I believe techie007's answer should solve your problems. –  surfasb Nov 16 '11 at 8:50
    
Thanks for the tip. I just updated to the latest driver and it did not fix it. –  David Silva Smith Nov 16 '11 at 14:53
add comment

1 Answer 1

up vote 2 down vote accepted

Switch to Windows Aero mode. This has been discussed on the DisplayLink forum as a known issue when not using Aero.

To turn Aero on:

  1. Right Click on the Desktop
  2. Click Personalize
  3. Select an Aero Theme.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.