Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to use a unique way to use console on my windows setup. Previously I used putty for remote access to linux servers and cygwin to have unix-like tools on windows.

Then I discovered kitty which is a patched putty and have added the puttycyg patch. It provides the same way to connect to remote and local console.

However, there is a strange behavior using vim when connected to the local console (using the puttycyg patch) : keys display A/B/C/D and replace the current character by these letter. In insert mode it does replace the caracter, in normal mode, no modification is made to the document even if the caracter is displayed as replaced.

For instance, when I type :

fixed bug with product deleted

I get :

fixed  bbug wiwith  prprodudueleteted

I have read a lot of questions about this type of issue 3, [4] and googled it but there is no answer that work for me.

The issue is present only for the setup kitty+puttycyg patch : cygwin alone works perfectly (and putty alone works also for access to linux servers).

Any help would be appreciated !

EDIT : I have tested without my usual vimrc. The result was different because there double insertion issue disappeared and I had issue with direction keys instead.

I could correct it with : set term=builtin_ansi but I'd like to have my full vimrc. I will try today to add options one by one to see which one isthe faultive.

share|improve this question

migrated from stackoverflow.com Nov 15 '11 at 22:18

This question came from our site for professional and enthusiast programmers.

    
While you clearly thought Superuser was a better site for this question because you searched for an answer there, you still decided to post it here? –  Juhana Nov 15 '11 at 12:34
    
ok, can it be moved to Superuser ? –  kamaradclimber Nov 15 '11 at 16:35
    
It sounds as though you need to file a bug report with the kitty and/or puttycyg developers. –  Andrew Schulman Nov 17 '11 at 21:27
    
maybe but I think, as this is a common ug with bad config of putty, that there maybe a conf tweak to be sure. –  kamaradclimber Nov 18 '11 at 6:45
    
no answer from the kitty devs... –  kamaradclimber Nov 23 '11 at 14:36

1 Answer 1

up vote 1 down vote accepted
+50

This may be due to a lack of a .vimrc file.

I experienced the same issue when first using the mintty terminal instead of the default Cygwin terminal. Adding a .vimrc file seemed to solve it. If you don't have a .vimrc file, I would suggest using the example one included with the vim installation:

cp /user/share/vim/vim73/vimrc_example.vim ~/.vimrc
share|improve this answer
    
In fact I have a [.vimrc ][github.com/kamaradclimber/Dotfiles/blob/master/.vimrc] and I have seen that not using it changed somewhat the situation : see me edit of the question. –  kamaradclimber Nov 24 '11 at 6:51
    
ok, this is definitely due to my vimrc : without vimrc it works like a charm, with the example, it works too. I need to check all the option of the vimrc file. thanks @Jacob –  kamaradclimber Nov 24 '11 at 12:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.