Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have downloaded Tweepy, and I locate its folder in the following path, where I have other libraries such as Pygame and swampy:

C:\Python25\Lib\site-packages

… but when I import it – even in the command line – to make sure that the installation was successfully done, it says:

import tweepy
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "C:\Python25\lib\site-packages\tweepy\__init__.py", line 14, in <module>
from tweepy.api import API
File "C:\Python25\lib\site-packages\tweepy\api.py", line 8, in <module>
from tweepy.binder import bind_api
File "C:\Python25\lib\site-packages\tweepy\binder.py", line 22, in <module>
raise ImportError, "Can't load a json library"
ImportError: Can't load a json library
share|improve this question

migrated from stackoverflow.com Nov 16 '11 at 5:09

This question came from our site for professional and enthusiast programmers.

    
you need to follow installation instructions for tweepy: code.google.com/p/tweepy –  Dmitry Beransky Nov 16 '11 at 2:28
    
python packages can be kind of a mess and vary quite a bit in requirements and needs in regard to your python path. That is why it is recommended that you use pypi.python.org/pypi/pip or pypi.python.org/pypi/setuptools –  DanLeaningphp Nov 16 '11 at 3:26
    
Dmirty, I downloaded Tweety from the link you provided, but for me it wasn't clear where to locate it after that!! –  Elbunderi Nov 16 '11 at 3:40
    
a paid nerd, thanx for the response.. –  Elbunderi Nov 16 '11 at 3:45
    
Daniel, thanks for the suggestion; I working on it right now, hope this will solve my problem.. –  Elbunderi Nov 16 '11 at 3:45
show 1 more comment

1 Answer

You are getting this error because your python installation 2.5 does not have any json libraries that Tweepy is looking for. Tweeppy currently tries to use the simplejson library, the json library or the django.utils library, if you don't have then it throws the error you see now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.