Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to mount an ext3 filesystem on a device with uid, gid, umask options set. When I use these options during mount, I get an error.

Below is the command I am using to mount:

mount -t ext3 -o uid=1001, gid=1001, umask=0066 /dev/mapper/mdev5 /dir

Is there any alternate to do so using mount?

share|improve this question

migrated from stackoverflow.com Nov 16 '11 at 13:00

This question came from our site for professional and enthusiast programmers.

    
Why do you think umask is an option you can set with ext3 filesystems? – sarnold Nov 16 '11 at 11:29
    
Check the allowable mount options for ext3 in your mount man page. As far as I'm aware, umask is not available for ext3, and from a brief reading I'm not sure uid and gid are either. – drfrogsplat Mar 27 '12 at 6:08

Read manpage for mount command. It says,

-o, --options opts Options are specified with a -o flag followed by a comma separated string of options

so, your command should be,

mount -t ext3 -ouid=1001,gid=1001,umask=0066 /dev/mapper/mdev5 /dir

(without space between options)

share|improve this answer
    
ext3 does not have an uid option, at least not on ubuntu 12 and older. – Johan Lundberg Oct 22 '13 at 18:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.