Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm generating PDF figures in Adobe Illustrator CS5 that include embedded images. I've noticed that the images look dramatically different when I display the same PDF in Preview, Skim or Adobe Reader (I'm on OS X). See screenshots. Adobe Reader displays them "correctly" while Skim and Preview blurs the image out each in a different way.

Is there a setting I can set when saving my PDF from Illustrator so that the images are displayed correctly in Skim and Preview?

The PDF was generated in Illustrator and saved without any compression or downsampling.

The original PDF is here: http://ge.tt/8iZMR2A

Adobe Reader 9

Adobe Reader 9

Skim 1.3.18

Skim 1.3.18

Preview 4.2

Preview 4.2

Super User's client-side PDF renderer

enter image description here

share|improve this question
    
    
Thanks for finding that, but this is not a duplicate. The other question deals with text rendering, which is handled completely differently from image rendering. –  AndyL Nov 16 '11 at 19:07

2 Answers 2

up vote 4 down vote accepted

Most likely both Skim & Preview are buggy in that they don't respect Interpolate flag on the image. We used to have a similar bug in SumatraPDF.

If that's the case, unfortunately there's nothing you can do.

You can try to set it explicitly to false (it's supposed to be false by default, but it's possible that Skim & Preview assume it's true and would work correctly if it's set explicitly to false) but I don't know how you can do that in Illustrator (or if it even allows for such level control).

You might wonder: what is this Interpolate flag I speak of? Unfortunately, explaining this requires explaining PDF file format, which is beyond the scope of this answer. The flag is described in page 207 of the PDF spec (currently linked from here).

share|improve this answer
    
Thank you for the details. I am a big fan of SumatraPDF when I'm on windows! –  AndyL Dec 28 '11 at 14:35
    
I've just tried with Skim: setting the Interpolate flag has no effect (even with explicitly setting to false). –  topskip Dec 31 '12 at 16:07

Different viewers use different viewing implementations based on their interpretation of the PDF spec version(s) they are aiming to support.

This will be further compounded when you start crossing platforms, which can use entirely different graphic rendering subsystems (etc.).

In much the same way as there's no "Make this look exactly the same on every browser" option in DreamWeaver, I think you're best best is to figure out a set of settings that make your PDFs look as good as possible on as many different readers as you can. That will take testing and tweaking to develop repeatable procedures that can be used on future PDFs.

share|improve this answer
    
I appreciate this, but I was really hoping for some insights into what those settings are? For example, do you have any ideas as to how to figure out what internal representation my image is stored in? And how I could systematically explore other internal representations? –  AndyL Nov 16 '11 at 16:43
    
Really it just looks like Skim and Preview are applying anti-aliasing to the output, and the PDF settings may not actually have any effect on that. I can't personally go into the depths of settings/options on Illustrator's output as I'm not heavy user, perhaps others' will come along with some insights. –  Ƭᴇcʜιᴇ007 Nov 16 '11 at 16:57
    
@AndyL Additionally, it turns out this question is a duplicate (IMO anyway), so I'll tag the possible dupe onto you question, and you can check out the info provided there. To garner further/different answer to that question, perhaps start a bounty with additional comments regarding your specific situation. –  Ƭᴇcʜιᴇ007 Nov 16 '11 at 17:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.