Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm working in Eclipse one night, (also using Android's DDMS from the commandline). The next morning, I open the lid... attempt to run Eclipse and get an error.

me$ sudo /Applications/eclipse/eclipse
JavaVM: requested Java version ((null)) not available. Using Java at "" instead.
JavaVM: Failed to load JVM: /bundle/Libraries/libserver.dylib

So I then attempt to find out where my JDKs are pointed:

me$ ls -la /System/Library/Frameworks/JavaVM.framework/Versions/
total 64
drwxr-xr-x  12 root  wheel  408 Nov 16 10:44 .
drwxr-xr-x  12 root  wheel  408 Sep  7 09:39 ..
lrwxr-xr-x   1 root  wheel    5 Sep  7 17:07 1.3 -> 1.3.1
drwxr-xr-x   3 root  wheel  102 Dec  2  2009 1.3.1
lrwxr-xr-x   1 root  wheel   10 Sep  7 17:07 1.4 -> CurrentJDK
lrwxr-xr-x   1 root  wheel   10 Sep  7 17:07 1.4.2 -> CurrentJDK
lrwxr-xr-x   1 root  wheel   10 Sep  7 17:07 1.5 -> CurrentJDK
lrwxr-xr-x   1 root  wheel   10 Sep  7 17:07 1.5.0 -> CurrentJDK
lrwxr-xr-x   1 root  wheel   10 Sep  7 17:07 1.6 -> CurrentJDK
drwxr-xr-x   9 root  wheel  306 Nov 16 10:44 A
lrwxr-xr-x   1 root  wheel    1 Sep  7 17:07 Current -> A
lrwxr-xr-x   1 root  wheel   59 Sep  7 17:07 CurrentJDK -> /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents

Everything looks normal so far...

me$ ls -la /System/Library/Java/JavaVirtualMachines/
total 0
drwxr-xr-x  2 root  wheel   68 Nov 16 10:44 .
drwxr-xr-x  5 root  wheel  170 Nov 16 10:44 ..

Apparently, my virtual machines have been deleted or moved?

I'll probably be able to just re-install Java, but does anyone have any insight into why this may have happened or how to prevent in the future?

share|improve this question
    
Apple released a Java update a week ago. Maybe something went wrong during installation? – Daniel Beck Nov 16 '11 at 17:27
    
Thanks for the tip, Daniel. I installed that specific update and it installed into the correct location. – weisjohn Nov 16 '11 at 17:52
    
Does your eclipse.ini specify a path to the VM? – sweetfa Apr 25 '12 at 21:18

You must log in to answer this question.

Browse other questions tagged .