Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two Windows 7 machines connected to a router. I created a shared folder on machine A, and I can access it from machine B. The transfer speed is great.

However, there is sometimes a long initial delay when I try to access the shared folder from machine B. I'll click to open the folder, and windows explorer pauses for a few minutes before actually loading the contents of the folder. After it loads, however, I can navigate the subfolders and edit files with no noticeable delay. Then, some time later, I will get the huge delay on saving a file, after which subsequent saves have no delay.

What is the problem here, and how can I fix it?

share|improve this question
    
BTW, I have not set up a Homegroup. –  Isaac Sutherland Nov 16 '11 at 17:25
    
Is it actually taking real "minutes"?? –  techie007 Nov 16 '11 at 17:32
    
> 30 seconds. I haven't measured it and it doesn't happen very often, but sometimes it feels like 2 minutes or more. –  Isaac Sutherland Nov 16 '11 at 17:45
    
I just measured it at 65 seconds. –  Isaac Sutherland Nov 16 '11 at 17:56
add comment

2 Answers

Windows has a idle timeout for network drive connections; by default it's 15 minutes. So after 15 minutes of not using the share it will disconnect and the next time you go to use it you will have to wait for the connection to be made again (as well as any authentication processes that go along with it).

This really shouldn't take "minutes" to happen (maybe a couple seconds), but still this may be what you're running into.

You can see how long your idle timeout is set to by opening a command prompt and typing:

net config server

You can set the timeout limit (in minutes) as such:

net config server /autodisconnect:<#ofminutes>

You can turn off the idle timeout completely by entering:

net config server /autodisconnect:-1

See this MS KB article for more info.

share|improve this answer
    
I changed the timeout to 1 minutes using net config server /autodisconnect:1 on computer A, closed all network windows on computer B, waited 3 minutes, and then open up the share again and edited some of the files, with no significant delay. Is this a conclusive test that whatever is causing the >60 second delay is not authentication, or would I need to completely shut off computer B for few minutes to be absolutely sure? –  Isaac Sutherland Nov 16 '11 at 18:07
    
If I leave the network share alone for a few minutes, when I come back I experience a ~ 3 second delay. That's probably what you are talking about above, and it's fine by me. But it seems to be a separate issue, since I sometimes have to wait for a full 60 seconds. –  Isaac Sutherland Nov 16 '11 at 18:42
1  
You should consider doing speed and connectivity tests on the infrastructure next. Ensure your wires are good, eliminate any routers/switches in the chain, etc. and see how it works. Basically stick a (crossover) cable between the PCs, hard set the IPs to static and see how it behaves. –  techie007 Nov 16 '11 at 20:46
add comment
up vote 0 down vote accepted

The solution was to keep the hard disk from spinning down. (Actually, I switched to Ubuntu before discovering this, so I don't know how or whether you can prevent auto spin down in Windows. Shortly I'll post another question/answer regarding avoiding the long delay in Ubuntu.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.