Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a device that I connect to my host Ubuntu machine via Ethernet over USB. It shows up as usb0 in ifconfig and the device always has the same address: 192.168.0.1. I have the following two problems:

  1. When I initially connect the device, the interface will connect and disconnect several times before settling down. I suspect this is because the dhclient is trying to obtain an IP address. The device does not support DHCP and this fails several times.
  2. After the interface is stable, I have to configure the interface manually with ifconfig.

To solve the two issues I tried configuring /etc/networking/interfaces:

...
    allow-hotplug usb0
    iface usb0 inet static
        address 192.168.0.2
...

This does not seem to work at all and the interface never shows up. I also tried configuring the interface in /etc/dhcp/dhclient.conf:

...
interface "usb0" {
  fixed-address 192.168.0.2;
}
...

Anyone know what I am missing?

share|improve this question
    
Can you clarify what you mean by the device not supporting DHCP? This is not something a device can choose to support or not support. –  Paul Nov 16 '11 at 22:55
    
@Paul: What I meant is that the device will never act as a DHCP server and give an IP address to the host. –  waffleman Nov 17 '11 at 16:14
    
What is this device? It is a computer of some kind, a phone or something? Can you provide an excerpt of dmesg when it is plugged in? –  Paul Nov 17 '11 at 20:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.