Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This issue has bugged me on multiple laptops for at least three years now, and I was wondering if anyone had similar experiences.

The problem is that waking up from sleep results in a hang or BSOD, but only if bluetooth is enabled. This does not happen every time, but often enough that you have to be careful before using sleep mode at all.

I think the most probable cause is the Windows driver (BTHUSB.SYS) for the particular bluetooth adapters i'm using, so I must specify the systems a little more. In both machines there has been BTHUSB errors in the Windows event log, but even these don't show up always.

Apple MacBook (first generation)

  • Intel 945GM chipset (for Core Duo, not Core Duo 2)
  • "Built-in Bluetooth 2.0 + Enhanced Data Rate (EDR)"
  • Windows XP, Microsoft Bluetooth Driver (BTHUSB.SYS)
  • wakeup never crashes in MacOS, only in Windows
  • I don't know how you disable bluetooth in BIOS, so haven't tested without
  • sometimes just bluetooth goes down but Windows stays up

Dell Latitude D380

  • Intel GM965 chipset
  • Dell Wireless 360 Bluetooth Module
  • Vista x64, Windows 7 x64, Microsoft Bluetooth Driver (BTHUSB.SYS)
  • wake-up from sleep works reliably if I disable bluetooth in BIOS
  • No error messages in event log (Windows 7)

I don't expect that this can be solved, but I'd like to know what machines to avoid in the future. It was really a surprise that the Dell had the exact same problem as the older MacBook.

share|improve this question
    
Can you look in your Event Management log and post any errors you think relevant here? –  caliban Sep 4 '09 at 15:40
    
A similar problem happened to my toshiba laptop. Fixed by installing latest updates\hotfixes for windows xp. –  Aziz Sep 4 '09 at 19:44

2 Answers 2

Sleep problems occur again and again on this forum.
This is a retake of my answer for thread 23820.

Ideas for resolving not coming out of sleep:

  1. Look in your BIOS for the suspend ACPI options and try to switch modes among "S1 and S3", "S1", "S3" etc.
  2. Ensure "Allow this device to wake computer" is checked in in "Device Manager/$device$/ Properties/Power Management", where $device$ stands for keyboard and mouse.
  3. Turn off Hybrid sleep, see explanation here (for vista, but is the same)
  4. The hibernation file is sometimes disabled by disk cleaning, to restore do in cmd run as administrator "powercfg -h on".

Note: Any of the above manipulation that doesn't help should be undone.
Item 1 was the one that worked the last time this question was asked.

In Windows 7 one can use the following command to troubleshoot sleep problems and return a detailed report:

powercfg -ENERGY

image

share|improve this answer

I was wrong.

The problem with Dell Latitude D380 was a broken DDR2 SO-DIMM module, and had nothing to do with bluetooth.

Replacing the memory fixed the issue. But I figured this out only after the machine started to give memory errors during the boot process.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.