Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I ./configure, I get this error:

configure: error: libdb is required

I signed up for an Oracle account (yak shaving), downloaded Berkeley DB, untarred and unzipped, wrestled with the unhelpful README, successfully configured, maked, and make installed. But the OpenCOBOL configure script still doesn't see the library.

share|improve this question

1 Answer 1

The configure script cannot find Berkeley DB; you have to tell it where libdb is.

$ ./configure CPPFLAGS="-I/usr/local/BerkeleyDB.5.2/include/" LDFLAGS="-L/usr/local/BerkeleyDB.5.2/lib/"
$ make
$ make install

Updated README

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.