Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a problem with Dropbox which seems to be quite common (the problem apperas on all sorts of systems - I'm running on Ubuntu 11.10). From the reading I've done, it seems the problem is that the operative system doesn't give Dropbox all the permissions it needs in among the files and folders, and the common suggested solutions are to either

a) unlink and relink the computer (tried this with no success), or
b) change ownership of the dropbox folder to the current user

Since a) didn't work, I attempted b). I navigate in my terminal to the dropbox folder (located at /media/data/Tomas/Dropbox and run

$ sudo chown -R tomas:tomas .

It runs for about a second, then exits without any messages (indicating that it actually does some work but doesn't run into any problems, right?). When I then run ls -l all files are still listed with root:root as owner. I've tried this non-recursive too, i.e. on only a single file, but with the same result.

Why doesn't chown do what it's supposed to do here?

Some information about my system:

I'm running a dual-boot system with Ubuntu 11.10 and Windows 7. The dropbox folder is located on an NTFS partition which is not the system partition for either operative system. Syncing works well on Windows, but not on Ubuntu.

share|improve this question
up vote 2 down vote accepted

From /media/data I'm guessing you have the Dropbox folder on an external or removable drive. If the drive is formatted using FAT ("vfat" in df -T), you cannot change the owner as the filesystem simply does not have such a concept.

share|improve this answer
Yes, it's a separate NTFS partition. – Tomas Lycken Nov 21 '11 at 14:09
But how do I let dropbox change files on the partition if I can't control the permissions? – Tomas Lycken Nov 21 '11 at 14:12
If it's NTFS, then make sure ntfs-3g is installed; chown should work. You might need to create an empty /media/data/.NTFS-3G/UserMapping file and un-/remount. – grawity Nov 21 '11 at 14:15
It turns out this was indeed related to the file system and how I mounted it. – Tomas Lycken Feb 29 '12 at 14:00

I'm not totally sure about this, but maybe you need to change the ownership of the Dropbox folder itself. The command you're using changes the owner of every file/folder inside /media/data/Tomas/Dropbox, but doesn't explicitly call the folder itself.

Try passing the path of the Dropbox root folder to chown like this:

sudo chown -R thomas:thomas /media/data/Tomas/Dropbox

If Dropbox is running as user 'tomas', you should also run a chmod -R command on this folder that gives 'tomas' all permissions for the directory tree. AFAIK Dropbox can't change the permissions itself.

In fact, ownership should be irrelevant as long as the user running Dropbox is granted read/write permissions on the entire Dropbox directory tree, so chmod might be the more important of the two.

share|improve this answer
I've run sudo chown -R tomas:tomas /media/data/Tomas/Dropbox and sudo chmod -R 777 /media/data/Tomas/Dropbox without any error messages. The files are still listed as -rwxrwxrwx root:root when I run ls -l, and Dropbox is still having problems syncing... – Tomas Lycken Nov 17 '11 at 13:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .