Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Just built a new system with the following problem components:

Corsair 650w PSU

Gigabyte Super OC GTX 560

ASUS P8Z68-VPRo motherboard

I turned the machine on first without installing the graphics card and it turned on fine. I then installed the card and powered on, but nothing happened at all. Seemed no power was in the system (LEDs are however alight on the motherboard) I removed the card, but the system still wouldn't power on.

Assumed the PSU was faulty and had it replaced.

Next time I installed the graphics card at the start and no power again. Not even a flicker of life (literally nothing at all). I removed the card and still the same problem as before.

Is it possible the graphics card is faulty and immediatly kills my power supply before the system even flickers? Or have I had 2 faulty power supplies? Or am I just making an amateur instaltion mistake?

Many thanks.

share|improve this question
did you plug in the 6 pin or 8 pin graphics card power? – Journeyman Geek Nov 17 '11 at 15:34
usually GFX cards have an alarm if the 6-8pin power is left un-connected – geocoin Jan 13 '12 at 10:31

There are a number of reason for this. Check all the connections on the motherboard. It could be a bad power switch, try plugging the reset button into the power pins on the motherboard and using it. Also check and make sure your RAM is seated properly, because although very rare, motherboards might not show signs of life until the RAM is booted properly.

It could also be a bad motherboard if none of the other solutions work. Good luck.

share|improve this answer
Rather than swapping headers around, you can just take your screwdriver and short the power pins to start, no button required. I agree that this could potentially be a problem with the board itself - there might be an electrical problem related to the PCIe slots. I think a GPU or RAM problem is more likely, though. – Shinrai Nov 17 '11 at 16:06

try for a totally lean setup. one memory module, the CPU and the heatsink.

re-seat and double check EVERYTHING. the CPU, the RAM, try the RAM module in different slots, disconnect the entire front panel connectors and just hook up the power switch. swap with the reset switch as already suggested, make sure all fans are connected to the correct headers.

make sure you have all power connected properly - main 20+4 pin ATX connector, extra 4-pin CPU power (socket should be somewhere near the CPU socket)

That MOBO has onboard graphics so plug your monitor into that.

if you can get hold of another PSU to eliminate that it's not the PSU (in this minimal config you won't need a lot of Watts, in fact you won't even need a full 24 pin ATX, just a 20 pin one as the extra 4 pins are for the PCI-Express graphics card power (through the slot) but it does need the separate 4-pin CPU (2x yellow and black) AKA the P4 connector.

Finally, there could be a MOBO fault. I've heard a lot of people complaining that ASUS Sandy Bridge boards have not been anywhere near their usual level of quality and have had higher levels of total failure (sorry this is totally anecdotal, but coming from people who build a lot of PC's)

once you've eliminated the PSU and loose connections as the culprit then suspect the MOBO. a bad CPU will usually still get the board to power on, even if it wont POST or do anything else except run the fans.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .