Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install Windows 7 inside of kvm on Ubuntu 10.04. Previously I've installed guest Windows XP and guest Ubuntu without incident. However, when I tried to install Windows 7, this happened:

First, multiple CPUs caused a blue-screen. That's fine, I guess I'll only have 1 cpu.

Then, I come across another problem. Windows can't see my virtual HDD. It asks me to insert a driver CD. I've downloaded this Red Hat Virtio driver and tried to use that. Windows recognizes it's a driver, but after I select it, it says it didn't find any new hardware using that driver*. Of course for that last one, I added a Virtio HDD instead of the IDE HDD, but no luck.

*I get

No new devices could be found. Make sure the driver files are correct and located on the driver installation media.

Has anyone successfully installed win7 and if so, did you encounter this problem and find a work-around?

I have kvm version:

$ kvm --version
QEMU PC emulator version 0.12.3 (qemu-kvm-0.12.3), Copyright (c) 2003-2008 Fabrice Bellard
$ modinfo kvm
filename:       /lib/modules/2.6.32-35-server/kernel/arch/x86/kvm/kvm.ko
license:        GPL
author:         Qumranet
srcversion:     FC0D2EE344D3C88A41BA5A4
depends:        
vermagic:       2.6.32-35-server SMP mod_unload modversions 
parm:           oos_shadow:bool
parm:           ignore_msrs:bool
$ modinfo kvm_intel
filename:       /lib/modules/2.6.32-35-server/kernel/arch/x86/kvm/kvm-intel.ko
license:        GPL
author:         Qumranet
srcversion:     5C339EB72FC5D22420654DC
depends:        kvm
vermagic:       2.6.32-35-server SMP mod_unload modversions 
parm:           bypass_guest_pf:bool
parm:           vpid:bool
parm:           flexpriority:bool
parm:           ept:bool
parm:           unrestricted_guest:bool
parm:           emulate_invalid_guest_state:bool
parm:           ple_gap:int
parm:           ple_window:int
share|improve this question

migrated from stackoverflow.com Nov 17 '11 at 20:44

This question came from our site for professional and enthusiast programmers.

1 Answer 1

I have not presonlly used KVM, however I have exlerience with several other virtual machines. The last time I had issues with installing an os in the virtual machine, it turned out to be a version issue. Verify the virtual machine, and version you are using is compatible with Win7. Your virtual machine seems tio pre-Win7. Try upgrading your KVM.

share|improve this answer
    
I'm not sure how to check, but I tried to add to the question what version I have.... Does that help? –  Robert Martin Nov 17 '11 at 20:58
    
The version of KVM you're using is getting close to two years old -- 0.12.3 was released in February 2010. Upgrading is likely to solve your problems. –  duskwuff Nov 17 '11 at 21:01
    
Okay, I am cloning [kvm](git://git.kernel.org/pub/scm/virt/kvm/kvm.git) and then I plan on doing make and make install... That's what you're suggesting, right? –  Robert Martin Nov 17 '11 at 21:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.