Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In testing some machine hardening settings I noticed what appears to be a bug in Windows XP's firewall. If you open firewall.cpl and go to the Exceptions tab you can add exceptions for known applications and individual ports. If you check the checkbox for, say, Remote Desktop, then it allows 3389 in so people can RDP to the machine.

If you go to the Advanced tab you can set firewall exceptions for individual interfaces. You should be able to disable the Remote Desktop exception in the Exceptions tab and enable the exception for RDP for each desired individual interface. If I do this for a single interface, then try to RDP to the machine using the IP address assigned to that interface, sometimes it will let me through, sometimes it won't. If I do manage to get it working it works exactly as expected. If, however, I disable the interface and then re-enable it the exception still shows up in the firewall UI and the settings still appear to be the same if I do netsh firewall show portopening, but for whatever reason it starts dropping the connection attempts.

I'm mostly wondering if someone can verify this issue, whether it's widely known, and if there's any sort of workaround for it. We'd like to be able to only allow certain services over a specific interface, but with XP's built-in firewall this function seems to be broken.

share|improve this question
1  
I stopped using (disabled) XP's firewall many years ago,. I use the old Sygate 5.6.2808 firewall instead, it is no longer supported but works very well, much better than the built in XP firewall...oldversion.com/Sygate-Personal-Firewall.html –  Moab Nov 18 '11 at 19:21
    
How are you disabling the interface? And what do you mean disabling the interface? All incoming connections are blocked to whatever port, unless there's an exception for that port. –  barlop Nov 18 '11 at 20:32
    
@Moab I loved sygate, and it's port logger. i'll try it again! –  barlop Nov 18 '11 at 20:32
    
barlop: I right click the interface in Network Connections and disable it. It's re-enabled before I test the connection again. –  maik Nov 18 '11 at 22:43
    
I'm unfortunately not able to use a separate firewall than what's included with the OS, but thanks for the suggestion. Just looking to see if this bug is avoidable or if I'm just missing something here. –  maik Nov 18 '11 at 22:44

1 Answer 1

I stopped using (disabled) XP's firewall many years ago,. I use the old Sygate 5.6.2808 firewall instead, it is no longer supported but works very well in XP, much better than the built in XP firewall

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.