Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 4gig flash drive, which I can read from but not write on, erase, nor format in any computer (tried in 7 different computers including xp, vista, and win7).

I want to erase all the data inside because it is useless. Once I erase something, it erases it and gives me an error that it can't find the file. Once I refresh the folder, the file comes back. I tried holding Shift + Del. I also tried to use the command to format it in safe mode, but it says "access denied". I don't have a write protection button or whatever it is on my flash drive. It's just a simple small 4 gig one.

share|improve this question
3  
Storage media often become read-only when their firmware detects errors while writing. Older flash drives have a relatively short lifetime... –  grawity Nov 19 '11 at 0:12
    
Is there anything i can do about it? i opened up the flash drive. is there anything i can do with the chips there or something that can fix it? btw, I can view the files in the flash drive and use them copy them etc. but i can't erase them or format it. i used the cmd too and few commands that i found online and it didn't work. please help me! –  Baruch Nov 19 '11 at 1:57
    
There's nothing you can do to the chips, and certainly not using home tools...(it'd be like fixing a watch using only an axe and sledgehammer.) Although you could try to low-level format the drive - I did that in a situation just like yours and the tool marked 15% of the blocks as bad - but there's no guarantee that the rest won't fail as well. Just buy a new drive while this one is still readable. –  grawity Nov 19 '11 at 4:22
    
On a related note, saying "I tried a few commands I found online" is not useful at all. Remember that help sites cannot read your mind. –  grawity Nov 19 '11 at 4:26
1  
Copy off the data, smash the chip, and toss it. –  Daniel R Hicks Nov 19 '11 at 13:50

3 Answers 3

up vote 4 down vote accepted

I want to erase all the data inside because it is useless.

If the data might be useful to a criminal, break open the casing until you can see the memory chips. Use a hammer to drive a nail through the chips.

It's just a simple small 4 gig one

You can probably replace it for $5-$10. Don't spend too long trying to get it working.

share|improve this answer

The HP USB Disk Storage Format Tool is about the best at this kind of thing - if it can't work on the drive then it's possibly beyond help.

http://files.extremeoverclocking.com/file.php?f=197

share|improve this answer
    
Alternate Link –  Journeyman Geek Nov 19 '11 at 12:55

Try this :

1) Right click 'My computer' -> Manage or Management -> Disk management

2) select your USB drive -> Right click ->"change drive letter and paths"

3) Then Rename it to a different letter

Check whether it starts working or not !!

If it doesn't.. then options left are: 1) using diskpart 2) using registry 3) Low level formatting

Steps are lengthy and precise (must be done with accurcy) it is better to do it from here:

http://goo.gl/fgHgX

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.