Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever KDE (I think) detects no mouse or keyboard activity for a while, it dims my laptop screen, then turns it off. I don't want that when I'm watching a movie.

Is there a setting somewhere to disable this behaviour based on running applications?

share|improve this question

2 Answers 2

Presuming you're using KDE4, you can try a command line call similar to the one's used here

From JanGerrit

Select allqdbus org.kde.powerdevil /modules/powerdevil setProfile <Profilename> 

Replace with the name of a preconfigured profile you added (I think there's something like this called "Presentation" or something similar)

And or

From Gen2ly

Came across today that dbus has an inhibit command i can use. Not the same thing but looks like powerdevil doesn't have the ability to disable power management.

qdbus org.freedesktop.PowerManagement /org/freedesktop/PowerManagement \
org.freedesktop.PowerManagement.Inhibit.Inhibit
share|improve this answer
1  
So far I've tried $ qdbus org.freedesktop.PowerManagement.Inhibit /org/freedesktop/PowerManagement Inhibit MPlayer muuu ...it doesn't seem to have worked. It does look like I'm on the right path though. –  György Andrasek Nov 19 '11 at 4:50

Since KDE 4.5 (or 4.6), functions have changed. Now use

qdbus org.kde.kded /org/kde/Solid/PowerManagement loadProfile <ProfileName>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.