Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded to Ubuntu 11.10. Ubuntu 11.10 comes with gtk(2, 24, 6).

I want to test one of my program with gtk (2,16,1), so how can I install gtk(2,16,1) and compile my pygtk program?

I try to install gtk(2,16,1) using:

gtk+-2.16.1$ ./configure --prefix ~/Home/opt/gtk2.16

However it results in the following error:

checking for BASE_DEPENDENCIES... configure: error: 
Package requirements (glib-2.0 >= 2.19.7 atk >= 1.13.0 pango >= 
1.20 cairo >= 1.6) were not met:

Is there any way to install multiple version of gtk on Ubuntu?

share|improve this question

migrated from stackoverflow.com Nov 19 '11 at 3:01

This question came from our site for professional and enthusiast programmers.

1  
I'd suggest you save yourself some potential trouble due to libraries getting mixed up, and install a virtual machine with the lowest version of the OS that you want your program to run on... –  ptomato Nov 18 '11 at 11:23

1 Answer 1

That will work fine. You just need to install the dev packages for glib, atk, pango, cairo and other dependencies of gtk+ (which you will discover as you go).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.