Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a Dell laptop (4 GB RAM, core i5 processor @ 2.67 GHz). I have a dual boot with Windows 7 and Ubuntu 10.04.

However I observe that there is significantly more heating when I use Ubuntu as compared to Windows. Consequently, battery life is much lower as well.

Is it just because of the difference in OS or is there some way to change the cpu frequency settings in Ubuntu to fix such a problem ?

share|improve this question

migrated from stackoverflow.com Nov 19 '11 at 3:06

This question came from our site for professional and enthusiast programmers.

    
I have only confirmed this issue with Ubuntu 11.04 Natty Narwhal and Ubuntu 11.10 Oneiric Ocelot. –  Deltik Nov 18 '11 at 2:39
    
I have the same issue, I didn't know you could put that kind of question on stackoverflow ^^ –  lc2817 Nov 18 '11 at 3:01
add comment

3 Answers

The PowerTOP program can help you determine where your battery life is going. It measures CPU wakeups, which drag the CPU out of low-power states, and assigns fault for the wakeup to specific programs. It's an amazing tool for software authors to improve their programs and for system administrators to find out why their data centers are so hot, or for individual users to find out how to improve their battery life.

I've been running it while writing this answer, and the top few lines of output look like this:

     PowerTOP version 1.13      (C) 2007 Intel Corporation

Cn                Avg residency       P-states (frequencies)
C0 (cpu running)        ( 6.1%)         2.80 Ghz    11.3%
polling           5.5ms ( 0.0%)         2.67 Ghz     0.4%
C1 mwait          0.2ms ( 0.1%)         2.00 Ghz     0.3%
C2 mwait          0.9ms ( 2.5%)         1.73 Ghz     0.4%
C3 mwait          4.2ms (91.2%)         1.60 Ghz    86.5%

Wakeups-from-idle per second : 246.3    interval: 15.0s
no ACPI power usage estimate available

Top causes for wakeups:
  39.3% (290.2)   [extra timer interrupt]
  19.4% (143.3)   npviewer.bin
   7.1% ( 52.7)D  firefox
   8.0% ( 58.9)   kworker/0:1
   6.4% ( 46.9)   [hda_intel] <interrupt>
   4.6% ( 33.8)   [kernel scheduler] Load balancing tick
   4.1% ( 30.6)   Xorg
   2.3% ( 17.3)   [radeon] <interrupt>
   2.3% ( 16.7)   USB device 1-5.2.2 : Apple Keyboard (Apple, Inc)
   2.2% ( 16.5)   [ehci_hcd:usb1, uhci_hcd:usb5, uhci_hcd:usb8, pata_jmicron, firewire_ohci] <interr

This is telling me that firefox and plugins account for 27% of my CPU wakeups; not a surprise, I'm streaming Pandora, and all they've got is some horrid Flash interface that eats a few watts for breakfast every morning.

Once you find what is eating your power, start looking for polling operations that can be converted into event-based operations. The Linux distributions have done a fair amount of work finding horrible polling interfaces and replacing them with event-based interfaces, but perhaps you're running something that hasn't yet been converted.

share|improve this answer
add comment

You should not be experiencing this problem with Ubuntu. I use Ubuntu 10.04 on my laptop and experience the opposite. I have longer battery life with Ubuntu, and most of the users I've read about and talked to have a better experience with Ubuntu. Open your System Monitor and go to the process tab, sort by % CPU and see if anything is taking up a lot of processing power. If it is, that is probably your culprit and you'll want to kill it and remove it from the startup if applicable.

share|improve this answer
    
To answer your question about the CPU Frequency settings, if you're using the GNOME environment (Ubuntu Classic), then you add an applet to your panel called CPU Frequency Scaling Monitor –  druciferre Nov 18 '11 at 2:36
    
I found an article that will tell you how to add such an applet in the Unity environment at http://www.ubuntugeek.com/cpu-frequency-scaling-applet-in-unity.html –  druciferre Nov 18 '11 at 2:38
    
I had an old HP laptop with overheating issues. It actually ran ONLY when using Ubuntu. Windows always got it shutting down the processor because it got too hot. So, my guess is: it's down to hardware issues. Clean up the cpu fan, check the ventilation, etc. –  Alfabravo Nov 19 '11 at 6:54
add comment

This should solve the overheating problem.

http://itsfoss.com/solve-overheating-issue-in-ubuntu-12-10/

It worked for me. I am using Dell N5010 laptop(i5 processor and 4GB RAM,1GB ATI graphics card) ubuntu 10.04 and 12.04.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.