Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Don't remember this from earlier, but my mouse is lagging when I refresh specific websites in Chrome and Firefox. I can't observe such lags with Internet Explorer.

Here's a video i made

I tested with AIDA64 and sometimes noticed very little and short lags.

Here's a second video

Any thoughts?


Hardware And Software Information

  • DELL Latitude E6420
  • Windows 7 64-Bit Enterprise
  • 8GB of RAM
  • Razer DeathAdder Black Edition mouse
  • Firmware: 1.00
  • Driver version: 1.02
share|improve this question
    
Have you tried updating intel.com and nvidia.com and dell.com drivers (auto match in IE for easy search & find). Maybe this will help. I'm doing this now for my E6420. –  MadBoy Nov 19 '11 at 13:07
    
What is your BIOS version? –  Boris_yo Nov 19 '11 at 15:05
    
A06. The newest from Dell. –  MadBoy Nov 19 '11 at 15:15
    
Have you tried a different mouse? –  techie007 Nov 19 '11 at 15:16
    
@MadBoy How is it working so far? Is it stable? –  Boris_yo Nov 19 '11 at 19:18
show 3 more comments

2 Answers

Try updating drivers with Intel Driver Update Utility and Nvidia and Dell website for your laptop. There may be some fixes that may solve your issue:

One find in Intel GPU drivers update is:

  • WebGL rendering anomaly in Google Chrome* and Mozilla Firefox* browsers resolved.

This may affect your mouse I guess. There seems to be a lot of other updates for E6420 as well so try that and see.

Additionally try to play with BIOS power management settings for your CPU. Especially disable C-State and see how it goes.

share|improve this answer
    
It is not recommended to mix drivers of different companies, but use your laptop manufacturer's drivers. –  Boris_yo Nov 19 '11 at 15:05
    
I don't have any problems by getting newest drivers straight from Nvidia or Intel. –  MadBoy Nov 19 '11 at 15:16
    
Besides since you've got the problems I would advise you to try it out by doing what I did.. maybe this will solve your problem :) –  MadBoy Nov 19 '11 at 15:18
    
@Boris_yo try disabling C-State at Power Management in Bios. It fixed some problems for me (slow Windows Explorer). It may fix yours problem with mouse. –  MadBoy Nov 27 '11 at 9:19
add comment

Basically, mouse cursor lagging will happen when too many processess are running on the laptop. And other way round, there is chance with antivirus software which leads this type of lagging.

Try to kill unwanted processess then test it and see.

You should see some better performance.

share|improve this answer
2  
I've got exactly same laptop with i7 4 cores / 8gb ram / SSD 500mb in/out and I can make the mouse lag just by running specific programs (and nothing else) like Royal TS which connects to multiple RDP connections at once. It's not related to too many processes for sure. Something else is going on. –  MadBoy Nov 19 '11 at 12:57
    
Not exactly. My processor is i5-2520M, 4GB initial RAM, Hard Drive 250MB, Intel HD with nVidia NVS 4200M in Optimus configuration. –  Boris_yo Nov 19 '11 at 15:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.