Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have changed in the searched preferences to google.com but still when I do search from the address bar (instant or non-instant) it will go to google.co.kr. Even though I change "Google.com in English", still same...

The only way is to open google.com website first, then do search in it.

So the question - is there any way to force Chrome to search in Google.com instead of google.co.kr? I understand there is some geolocational checking/redirecting, but there must be some way to force...

share|improve this question
    
having the same problem and looking forward to find some answer on this thread in near future. –  Allen Bargi Jan 12 '12 at 14:08
    
Actually there is a way, but you will not have instant search. Just create clone of default rule and replace {google:baseURL} with google.com. –  Pablo Jan 23 '12 at 16:58
    
Pablo - doing this prevents omnibox from returning "Instant" results though. –  alexleonard Jul 7 '12 at 10:30

7 Answers 7

up vote -3 down vote accepted
  • Have you marked the 'google.com' option as default?
  • If not mark it as default using the 'make default' button (appears on hover).
  • See the image below. It should be like that.

share|improve this answer
    
Yes, it's marked as default –  Pablo Nov 24 '11 at 1:40
    
Okies. Is it similar to above image? That means having 'google.com' as domain in all 3 columns. –  iAnuj Nov 24 '11 at 2:02
1  
Not exactly, because third column is non-editable. If I know what is correct search string template in order to make instant search also to work, then I could try to create new one maybe... But why google:baseURL is taking incorrect domain, I still don't get. –  Pablo Nov 24 '11 at 4:51
    
In that case you should add a new one with values same as in image and make it default. –  iAnuj Nov 24 '11 at 13:09
    
{google:baseURL}search?{google:RLZ}{google:acceptedSuggestion}{google:originalQ‌​ueryForSuggestion}{google:searchFieldtrialParameter}{google:instantFieldTrialGrou‌​pParameter}sourceid=chrome&ie={inputEncoding}&q=%s is default search string. How should I modify it to have instant searching working AND forcing to use google.com domain? –  Pablo Nov 28 '11 at 8:56

I created a new standard Search with the following settings:

Name: Google.com Shortcut: google.com and URL: https://www.google.com/search?q=%s&{google:RLZ}{google:acceptedSuggestion}{google:originalQueryForSuggestion}{google:assistedQueryStats}{google:searchFieldtrialParameter}sourceid=chrome&ie={inputEncoding}

and it works fine.

share|improve this answer

Go to the Wrench icon and select Options. In the Basics sections, click Manage Search Engines in the Search section. In that section you can modify each of the query strings, so you can change it to just "google.com".

share|improve this answer
    
Actually I did that and also put google.com/ncr, none helps –  Pablo Nov 20 '11 at 7:57

This is the easiest way, from Chrome help on the web:

Add a search engine: Scroll to the bottom of the dialog and fill out the following fields:

Add a new search engine: Enter a nickname for the search engine.

Keyword: Enter the text shortcut you want to use for the search engine. Use the keyword to do keyword searches.

URL: Enter the web address for the search engine -here you want to put: http://www.google.com/search?q=%s

share|improve this answer

Going to http://google.com/ncr disables the "country redirect" for me.

share|improve this answer
1  
Again, if I open google.com from address bar there is no redirection! So it doesn't make sense to "Go to .../ncr". I tried to change search engine preferences and put /ncr but still Chrome is redirecting me to google.co.kr –  Pablo Nov 20 '11 at 7:50

The answer is actually very simple.

When doing an omnibox search my desktop was returning google.co.uk, my laptop google.com so I knew something was up - and I really wanted the knowledge graph results from .com.

Follow all these steps in order.

  1. Go to http://www.google.com. If you're redirected to a country-specific site, click the "Go to Google.com" link in the bottom right of the Google home page.
  2. Do any search. This sets Google.com as your {google:baseURL} in a cookie.
  3. Click the wrench icon and select "Exit" to fully exit Chrome.
  4. Relaunch Chrome and try an Ombnibox search now.

This method will ensure that omnibox now returns results from at google.com and still searches instantly (if you have that option selected in your Chrome settings).

http://support.google.com/chrome/bin/answer.py?hl=en&answer=106514

share|improve this answer
    
I tried the above and the omnibox still searches the local google. –  Shimmy Dec 22 at 13:47

I encountered the same problem and found this solution. Note that I didn't use the "better trick" that was posted in July 2013 (it didn't work for me with OS X and Chrome 29.0.1547.65); I'm using the older method, to wit:

  1. Close all Chrome windows.

  2. Go to Chrome's user profile directory (for example, in Windows Vista and Windows 7 the path is: %LOCALAPPDATA%\Google\Chrome\User Data\. Under OS X, it's $USERHOME/Library/Application Support/Google/Chrome/.

  3. In the Default directory, open the file Preferences in a text editor like vim or Notepad.

  4. Find the two lines that include last_known_google_url and last_prompted_google_url and change the Google URL from http://www.google.tld/ (where .tld is .co.uk, .fr, .co.jp etc.) to http://www.google.com/ or any other Google domain.

  5. Save the file and restart Chrome.

  6. If you see an infobar that asks if you want to switch to your local domain or keep google.com, choose the second option.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.