Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

theage.com.au is a news site that loves to reload the page that I'm reading, which annoys the hell out of me. It also automatically starts playing any video on the page as soon as I start scrolling down. Is there any way to stop it from doing both of those things, preferably in Chrome (but Firefox would be interesting, too). Perhaps some extension or something? Ideally I'd like to disable it only for that one domain, because some sites do use auto-refresh for legitimate (non-annoying) purposes.

share|improve this question
1  

2016-04 Update

There's a new extension that was published since my original answer, called "Disable HTML5 Autoplay". It seems to work well. The author is responsive and development is active. As per the name, it is for HTML5 video elements, not Flash objects. You can get it here: https://chrome.google.com/webstore/detail/disable-html5-autoplay/efdhoaajjjgckpbkoglidkeendpkolai

As for videos powered by Adobe's Flash plugin, it appears that Chrome by default now attempts to detect whether a Flash object is "important" to the page and disables it if not, so you may find that sufficient. You can also set it to prohibit ANY Flash object from running automatically. Personally, I suggest doing this (or even removing the plugin if you do not depend upon it), as it has been a frequent source of major security vulnerabilities for years. You can do this in Chrome at: Menu > settings > advanced settings (link at the bottom) > Privacy header, Content settings button > Plugins header, "Let me choose when to run plugin content" option. You can also manage exceptions here, which would be pages on which plugins are automatically run.

In addition, I should point out that the auto-refresh blocking workaround in the original answer below was adapted from an answer to this question: http://stackoverflow.com/questions/18273767/how-can-i-block-page-autorefresh-in-google-chrome - I'm not aware of any new solutions at this time.

Original Answer

Unfortunately, I have researched for ways to do these things in Chrome, and found nothing that will work well, but I have a partial workaround here.

The best you can do to prevent refreshes is to use a bookmarklet or a user script extension like Tampermonkey to add the following Javascript to the domain in question:

window.onbeforeunload = function(){ return 'Disabled Auto-Refresh';};

If you want it as a bookmarklet, simply add "javascript:" to the front and make that the target of a bookmark. Click it when you're on the page you want to prevent from refreshing.

This will cause you to get the "Do you want to navigate away from this page?" popup when the site tries to refresh, which is annoying (thanks, Google), but at least you can tell it "no". It simply isn't possible to do this correctly in Chrome due to its limited extension API.

Similarly, there appears to be no good way to prevent HTML5 videos from playing automatically aside from blocking them outright. The closest I have seen anything come is this: https://chrome.google.com/webstore/detail/stop-youtube-html5-autopl/ajkibmginjljbmmpgnipfbcbmkcodaap that tries to pause videos, but the author admits that it doesn't have universal compatibility, and the reviews mention that it doesn't have a whitelist. I don't know whether it is once again Chrome's API limitations that are preventing us from doing what we want or just that nobody has made an appropriate extension.

share|improve this answer

Have you tried using Adblock for Chrome?

There is a FAQ on the website showing how to block for specific domains:

Adblock FAQ - How to Block Only a Few Sites

The format to block the ads on that domain would probably be something along the lines of...

@@*$document,domain=~theage.com.au

Adblock is available for Firefox, too, but it is not made by the same person.

Another fix that may stop the page from reloading is turning off javascript on that domain. You can accomplish this by to Tools (Wrench) -> Options -> Under the Hood -> Content Settings -> Javascript, and adding theage.com.au to block javascript on that page. One thing to note is that turning off javascript on some websites may cripple the responsiveness and useability of those websites, as they might rely on it heavily. After trying it out, it is mostly viewable.. but there were a lot of bits on the site that just disappeared when I used this. You might find it acceptable, but I would not recommend it (though I am including it here for you just incase you find you like it better).

share|improve this answer
    
I tried adding AdBlock with that configuration, but it didn't seem to stop the page reloading or stop the video playing. (I already had AdBlock Plus by the way.) – EMP Nov 23 '11 at 14:20

www.dailymotion.com has the annoying habit of reloading a lot of ads over and over, making the video play jerkily, but I found a somewhat cumbersome, but effective way to disable ad reloads without coding.

Written for Google Chrome Version 49.0.2623.87 m.

To stop www.dailymotion.com from refreshing adds constantly while watching videos in Google Chrome:

  • Type chrome://settings/content into the Address Bar. Press Enter.
  • In the "JavaScript" section:
    • Select "Do not allow any site to run JavaScript".
    • Select "Manage exceptions..." button.
    • Type www.dailymotion.com in "Hostname pattern" field.
    • Set "Behavior" to "Allow".
    • Click "Done" button in lower right.
  • In the "Plugins" section:
    • Select "Let me choose when to run plugin content"
    • Click "Done" button in lower right.
  • In a separate tab, navigate to preferred www.dailymotion.com video web page.
  • Go back to the Google "Settings" tab.
  • Type chrome://settings/content into the Address Bar. Press Enter.
  • In the "JavaScript" section:
    • Select "Manage exceptions..." button.
    • For the "www.dailymotion.com" "Hostname pattern", change the "Behavior" to "Block".
    • Click "Done" button in lower right.
  • Go back to the www.dailymotion.com tab.
    • Right-click on video player and select, "Run this plugin".
    • Watch your video ad-refresh free.
  • When video is over:
    • Go back to the Google "Settings" tab.
    • In the "JavaScript" section:
    • Select "Allow all sites to run JavaScript (recommended)" to return to "normal" operation.
    • Click "Done" button in lower right.
share|improve this answer

You could probably use flashblock if the videos are flash based - you'd need to click to activate then. You might need to whitelist sites you want flash to automatically load though

share|improve this answer

I haven't found a way to do this within Chrome, but I have found a workaround. I use Pocket to save pages I want to read later. If I save a page to Pocket, then retrieve it from there, there's no problem with the auto-refresh. It's an extra step, but it works.

share|improve this answer
    
What's Pocket? Please read How to recommend software for instructions on recommending software on Super User. Thanks for contributing. – Twisty Jul 25 '15 at 3:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .