Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to unzip a file in redhat but I keep getting this when I run unzip filename.zip

heckdir error:  cannot create file_name
                 unable to process file_name/bin/.

I'm guessing this has to do with the underscore in the file name. Is there any work around? Or if it's not the issue what can it possibly be?

When I Run unzip -l /home/db2inst1/db2files/ShaneScripts/trans_demo.zip it works fine and displays the contents of the file.

share|improve this question
3  
Shouldn't be a problem, underscores are fine on Linux file systems... that seems to be a checkdir error; (not a heckdir error) which is typically displayed when you are out of inodes. can you type df -h . in the directory you are attempting to extract in to see how much space you have left. or make sure you have permission to write wherever file_name is being created – Ahmed Masud Nov 21 '11 at 11:26

The only characters not allowed in filenames are '/' and the NULL byte (zero). Everything else, including spaces dashes and underscores, is allowed.

It's having a problem creating the file. Do you have perms in the directory you're in? I'd try to create a file or directory in the location where you are, and see what that does. It will most likely fail, and you can diagnose that.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .