Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's the thing.

There is an Autocad script file, extension .scr which by default opens in Notepad. It is a regular text file, in which I need to do some edits so I want it to open in Vim.

Upon going to Windows Explorer / Tools / .... / that list of file extensions, I see that it's not there (?!).

Not under .scr, not under anything remotely similar to Autocad, Autodesk, ... anything.

So I'd like to know, where could it be and how can I change it to Vim for the default open association?

Any clues?

Edit: Also, when I right click on it in Windows Explorer, there is no Open With ... option, so no luck there. Completely dumbfounded here.

Edit2: Solved the problem. Deleted everything related (and remotely related) to .scr in Registry, and it defaulted back to gvim, as my text editor. Don't know what caused it, nor what exactly fixed it. Nothing seemed to be associated with .scr in Registry, nor anything similar.

If anyone knows something about this, put it down as an answer.

share|improve this question
    
scr by default is also associated with the windows screensaver, this may be the reason you had problems. –  Moab Nov 21 '11 at 17:07
add comment

2 Answers 2

Solved the problem. Deleted everything related (and remotely related) to .scr in Registry, and it defaulted back to gvim, as my text editor. Don't know what caused it, nor what exactly fixed it. Nothing seemed to be associated with .scr in Registry, nor anything similar.

If anyone knows something about this, put it down as an answer.

share|improve this answer
add comment
  1. Right click on the file and click on properties.
  2. There should be a section that says "Opens with:". Click on the "Change..." button.
  3. Select the application you want. If it is not in the list, click on the "Browse..." button and find the application in your directory.
share|improve this answer
    
Nope. No such option. –  ldigas Nov 21 '11 at 16:11
    
Ah didn't notice you were on XP sorry. –  norlando Nov 21 '11 at 16:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.