Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried with Suse 11 (KDE), Xubuntu 11.10 and Lubuntu 11.10 and these systems only recognizes 800Mhz from my processor of 2Ghz!

The utilities I used are: linuxinfo, sysinfo, "system profiler and benchmark". And all of this only shows 800Mhz

My system specs are:

  • AMD Turion 64 Mobile MK36
  • 512 RAM
  • nVidia Geforce Go 6150 (I also tried with nVidia restricted drivers)
  • 120GB Hard drive

The weirdest thing is that Windows XP and 7 recognize the 2Ghz of my processor,

What can I do?

p.s. (It is not just the value of 800Mhz, I also feel my system very slow with linux)

share|improve this question
That processor achieves 2GHz by using a 800 MHz clock with a 10x multiplier. Are you sure it's not telling you that? Does it mention the multiplier anywhere in the utilities you tried? – Ƭᴇcʜιᴇ007 Nov 21 '11 at 16:17
800Mhz is usually the "powersave" mode frequency - does it increase when you have some application running? – Sathya Nov 21 '11 at 16:39

Looks like you have ondemand governor enabled by default. Please check and disable cpufreq or cpuspeed daemons on your PC to run on a full throttle.

share|improve this answer
Yes thats the case, but don't disable the functionality. It's a huge power saver. – user606723 Nov 21 '11 at 20:30

Mobile processors adjust their frequency according to workload, you may be seeing boot frequency.

See also

share|improve this answer

It's called dynamic frequency scaling and is not just for mobile chips (though modern mobile chips almost always do it for lower battery consumption). My desktop's i7 processor has SpeedStep and TurboBoost that dynamically change frequency depending on load, and AMD has there own similar schemes. Windows is possibly lying when it says your processor is 2GHz, when its likely operating at 800MHz unless under heavy load (when it operates at 2GHz). The dynamic frequency changing lowers power consumption when its not needed, allowing for less heat, less noise (from fans), and less power consumption. Try doing some heavy computations (on all your processors) and you likely will see in linux that your cpu frequency goes up to 2GHz.

share|improve this answer

As others have pointed out, this is probably related to power saving and just fine. When your computer is idle, the CPU works at 800Mhz. As soon as more processing power is required, the ondemand governor (part of the kernel), will scale the frequency up.

My laptop has a 2GHz dual core CPU, working at 800MHz when idle. Below, you can see a screenshot with an excerpt from /proc/cpuinfo and in the panel the Gnome CPU Frequency Monitor cpufreq-selector (chip with blue bar). Both from the text output and the graphical indicator you can tell the CPU is not running full speed.

enter image description here

The ondemand governor is considered optimal for about any realistic usage scenario. However, you can use a different governor such as performance if you really want your CPU at higher frequencies at all times.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .