Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Does mplayer actually allow custom seek times?  ie. change the default 10s to 4s.
I'm running mplayer natively in the terminal. ie. not via a gui wrapper such as smplayer.
Nothing changes when I follow the suggested method.

My conf file is ~/.mplayer/input.conf — It contains only the following 2 lines:

RIGHT seek +4
LEFT seek -4

I understand that seeking can be influenced by the location of key-frames (especially in video)... However I want this for audio only.

Because it didn't work with a .mp3, I tried it with an uncompressed .wav ... Still nothing changed.. My left and right keys still moved 10 seconds.

This is the command I used:

mplayer -input conf=~/.mplayer/input.conf  audio.wav

I tried larger values (seek 140) but it still didn't work..
Is this feature broken, or am I doing something wrong?

I'm using mplayer in Ubuntu 10.04

share|improve this question
up vote 1 down vote accepted

Well, the probleme is that mplayer don't undertand the ~ in ~/.mplayer/input.conf. run it as

mplayer -input conf=$HOME/.mplayer/input.conf  audio.wav

or better yet

mplayer audio.wav

as mplayer should look for the content of $HOME/.mplayer/input.conf without you asking for it.

share|improve this answer
@Rémi: I was aware that the option wasn't explicitly needed, but I hadn't realized that the = prevents the expansion... However, that doesn't explain the problem, because mplayer falls back to looking for input.conf in that directory... !!!??? What??? .. ok, the path was wrong (it didn't report an error.. ok-ish).. but then why shouldn't/wouldn't it work? .. the file was actually there... You have certainly highlighted the root of the problem... It clicked!... input.conf had a trailing space in its name... It works like a charm now with mplayer audio.mp3 :) ..*Thanks!* – Peter.O Nov 22 '11 at 5:46
PS. mplayer -input audio.wav doesn't work.. input must by followed by a command. The commands can be listed via: mplayer -input cmdlist – Peter.O Nov 22 '11 at 5:55
yep, forgot to remove it when copying and pasting command, it done now – Rémi Nov 22 '11 at 6:06
I think my space came from a copy-paste too ;) – Peter.O Nov 22 '11 at 6:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .