Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

To install meld on Mac OSX I try to run:

brew install meld

but I got the following error:

Error: No available formula for meld

What is the right way to install meld?

share|improve this question
you probably ought to switch out the accepted answer... – Zach Lysobey Jan 15 '14 at 23:10

5 Answers 5

up vote 3 down vote accepted

When this question was asked, it was not possible using Homebrew. They didn't support it yet.

There are alternative solutions to installing meld on OS X:

Use a different package manager, like Fink, which is mentioned in meld's installation manual, or MacPorts, mentioned in the issue in Homebrew's issue tracker.

You can probably also compile from source, but need to get the dependencies yourself. Installing one of the other package managers might be easier than that.

share|improve this answer
it is now possible, see – meduz Jan 30 '13 at 8:58
@meduz Changed the answer. Since I mention alternatives that used to work when this question was new, I decided against deleting the answer, as it might help those with the same issue with different software. – Daniel Beck Jan 30 '13 at 9:40

As pointed out by @meduz in the comment above, meld now compiles file in brew (haven't tested yet), please try it first, since my original answer is much older.

Today is already possible install it using Homebrew:

brew install meld

I got a issue with pygtk, when I execute meld it says:

Couldn't bind the translation domain. Some translations won't work.
Cannot import: pygtk
No module named pygtk

I already have pygtk installed from lion, and needed to export it to work:

export PYTHONPATH=/usr/local/lib/python2.7/site-packages/

Add the above line to your ~/.profile to set PYTHONPATH automatically when you open a terminal window.

share|improve this answer
it compiles fine on the current version of homebrew, could you please edit your answer? – meduz Jan 30 '13 at 9:00
Note you will have to install XQuartz (from MacOS Forge) before installing Meld. – Abhi Beckert Feb 18 '13 at 1:16
Note this is a lengthy install, took about 14 minutes on my (Ivy Bridge) machine. – Steven Lu May 25 '13 at 23:42
Note, for me, this still resulted in an error, which was addressed in this post on SuperUser:… – Brad Parks Sep 13 '13 at 17:24
In 2015 with Meld 3.14.0, XQuartz was not required for install. GTK+ appears to be running on the native X server? I'm not sure, but I know I don't have XQuartz installed. – Johann Aug 19 at 20:49

I believe that the current correct brew commands are

brew install Caskroom/cask/xquartz
brew install homebrew/x11/meld

However after running those commands I ended with the following, which I know that I have overcome on other installations on different macs in the past.

Couldn't bind the translation domain. Some translations won't work.
'module' object has no attribute 'bindtextdomain'
/usr/local/lib/python2.7/site-packages/gtk-2.0/gtk/ GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
/usr/local/Cellar/meld/1.8.6/libexec/bin/meld:155: GtkWarning: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
Traceback (most recent call last):
  File "/usr/local/Cellar/meld/1.8.6/libexec/bin/meld", line 155, in <module>
AttributeError: 'NoneType' object has no attribute 'append_search_path'

But this time I decided it wasn't worth my time since I couldn't remember the exact remedy.

Instead I found a simple DMG installer and script from Alex Kras to launch the Meld application installed by the DMG installer. The instructions are on his site. Note, though, that this DMG-installed version doesn't respond well to to the git mergetool input

share|improve this answer
I actually ended up abandoning the DMG version and went with the brew install. I could not get the DMG version to correctly understand git mergetool's output – Kirby May 5 at 22:09
Same problem as Kirby :( – BrunoJCM Jul 28 at 13:21

Try this

brew install homebrew/x11/meld

or this

brew tap homebrew/x11
brew install meld

Meld is in Homebrew's X11 repository. Running brew tap homebrew/x11 allows Homebrew to see Meld in that repository. (2015 answer)

share|improve this answer
Once installed how does one use meld? – evolutionxbox Oct 22 at 14:46

As the formula for Homebrew disappeared i want to mention an alternative. There's this build as OS X application which is simple to install. It was last built in December '14 and requires some tweaks if you want to use it from the command line. I have not yet tried to figure out how.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.