Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Amazon Linux machine running in an Amazon EC2 instance.

I am connecting to my office's VPN as follows:

sudo pppd pty "pptp pptp.<DOMAIN>.com --nolaunchpppd --loglevel 2 --debug" file /etc/ppp/options.pptp user <MYUSER> password <MYPASS>

I can see in /var/log/messages that I am connecting:

CHAP authentication succeeded

But when I ping a server located within the remote network it just hangs:

ping -I ppp0 newdev.<DOMAIN>.com

I can ping the machine without -I, but I get its external IP address:

ping newdev.<DOMAIN>.com
PING devserver.<DOMAIN>.com ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=109 time=15.5 ms
64 bytes from icmp_seq=2 ttl=109 time=15.4 ms
64 bytes from icmp_seq=3 ttl=109 time=14.5 ms

I'm sure I'm missing something, I'm just not sure what.

Routing table when connected:

Kernel IP routing table 
Destination      Gateway       Genmask         Flags MSS Window irtt Iface UH 0 0 0              ppp0 UGH 0 0 0             eth0   U 0 0 0               eth0         UG 0 0 0              eth0 
share|improve this question
If newdev.<DOMAIN>.com resolves to the external address, then I'd expect this behavior. Can you ping its internal address with -I? –  Paul Nov 22 '11 at 2:03
No, the same thing happens. It just hangs. If I connect to the same VPN from Windows 7 (and default gateway disabled) it resolves to the internal ip. –  user1058765 Nov 22 '11 at 2:07
I meant IP address - are you saying ping hangs when you ping the internal IP address? –  Paul Nov 22 '11 at 2:13
Yes, so the internal ip is If I ping that it just hangs. –  user1058765 Nov 22 '11 at 2:14
Are you able to post netstat -rn when connected? Santise if you need to. –  Paul Nov 22 '11 at 2:15

1 Answer 1

The network is not routed via ppp0

route add -net gw ppp0
share|improve this answer
Now I get route: netmask 000000ff doesn't make sense with host route –  user1058765 Nov 22 '11 at 2:26
My mistake, I missed a switch - answer updated –  Paul Nov 22 '11 at 2:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.