Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to build the linux kernel 3.0.4 on ubuntu 11.10 in virtualbox. Here are my steps:

  1. Download the source code
  2. tar xjvf linux-source-3.0.0.tar.bz2
  3. cd linux-source-3.0.0
  4. make menuconfig, changed nothing but used the default config and save to .config
  5. make

Actually I think it should be 3.0.4 because from the Makefile I could see


Then at stage 2 which is to make modules, an error happened:

ERROR: "__modver_version_show" [drivers/staging/rts5139/rts5139.ko] undefined!
make[1]: *** [__modpost] Error 1
make: *** [modules] Error 2

Perhaps because 3.0.4 is a new release so that I can not find any same problem asked nor any solution to it.

share|improve this question

migrated from Nov 22 '11 at 2:46

This question came from our site for professional and enthusiast programmers.

__modver_version_show() is an internal function which is only used when you have not enabled CONFIG_MODULE and enabled CONFIG_SYSFS. IOW, only when you have CONFIG_SYSFS but not CONFIG_MODULE in your .config, you will see this error.

For normal desktops, !CONFIG_MODULE && CONFIG_SYSFS is a broken configuration.

Given the setups you did, you should copy the .config of your kernel provided by your distribution to the top directory of kernel source code first, and then do "make oldconfig".

I am not a ubuntu user, to find your distribution kernel .config, please either search your /boot or check if you have /proc/kconfig.gz, and copy it (you need zcat to copy kconfig.gz as it is compressed) to the right place.

share|improve this answer

Provided that the config of Ubuntu,


I don't think the problem is due to this option. I tend to bypass this driver.

Driver Module » Staging » RTS5139 »<N>

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.