Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been struggling with a font issue which I hope you can help resolve. A few weeks ago I started seeing "Impact" as the default font on lots of webpages, rendering much of the content illegible.

I think this issue began after I installed other fonts, but I'm not sure. The issue occurs on Chrome, IE and Firefox which suggests it is a Windows issue. By the time I tried to revert the changes via System Restore, it was too late.

I tried to reset the default font but Windows does not seem to respond to that. When I click "Restore to default font settings" the button greys out but nothing else happens. No dialog box and no change in the issue. I've tried deleting the fonts in my font folder and re-installing them (from backup) but that did not work either. I inititially documented the issue here:

Any ideas? Thanks!

share|improve this question
Did you check the font settings within each browser? Can you download Firefox Portable and let me know if it also has the same problem? ( – iglvzx Nov 22 '11 at 7:01
checked the fonts in the browsers; tried changing each default font but it did not help. i just downloaded firefox portable and no change - the twitter page looks exactly the same. – J Alain Ferry Nov 22 '11 at 14:26
screenshot of the text under this thread. – J Alain Ferry Nov 22 '11 at 14:29
@JAlainFerry Have you checked to make sure standard fonts such as Arial and Times New Roman exist in your fonts directory? You can check this by going to Control Panel -> Appearance and Personalization -> Fonts and checking to see if those fonts are there. – John H Dec 2 '11 at 1:56

For Chrome visit chrome://settings/fonts and check if the default font is 'Impact'.

This may not be a problem with windows, but a problem with all your browsers. (Virus?)

share|improve this answer

Do you have Helvetica Extra Compressed installed on your machine? It seems as though Helvetica Extra Compress was taking over as the system default for sans-serif, instead of Arial. Once I removed the font from my system fonts, everything went back to normal.

Hopefully this helps.

share|improve this answer
Why do you ask about font X when the user has a problem with font Y? – Jan Doggen Nov 21 '14 at 20:23
@JanDoggen - Compressed Helvetica fonts appear similar to Impact, thus one could easily think they were viewing Impact when in fact it was a Helvetica font. The CSS in many web sites requests a Helvetica font first and then falls back to Arial or any Sans-Serif font if none of the previous are found. If any Helvetica font is present on the system then it will display it. – Porcupine911 Feb 28 at 2:51

Found a solution! I had to go into my fonts folder and delete a version of "Helvetica" font I had installed long ago. Once I deleted it, I updated my browser and everything was back to normal! So I'm guessing the font is Helvetica and not Impact.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .