Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to update my Windows 7 Professional 32-bit edition and when I try to tell Windows Update to scan for updates it failed with the error code 0x80096001.

I checked out WindowsUpdate.log and it appears this is the problem:

Validating signature for C:\Windows\SoftwareDistribution\WuRedir\9482F4B4-E343-43B6-B170-9A65BC822C77\muv4wuredir.cab: WARNING: Error: 0x80096001 when verifying trust for C:\Windows\SoftwareDistribution\WuRedir\9482F4B4-E343-43B6-B170-9A65BC822C77\muv4wuredir.cab WARNING: Digital Signatures on file C:\Windows\SoftwareDistribution\WuRedir\9482F4B4-E343-43B6-B170-9A65BC822C77\muv4wuredir.cab are not trusted: Error 0x80096001

How can I go about fixing this? It looks like it's just this one (corrupted?) file that's causing the problem.

Thanks!

UPDATE: Upon inspecting the file mentioned in the error message it appears that the file does not exist! What does this mean and how do I get it back?

UPDATE 2: Ok it appears that the file in question appears only for a split second when Windows Updating is trying to search (but fails) to find updates. So I guess the problem doesn't have to do with the file specifically then.

share|improve this question
    
It could be a corrupted user profile, create a new user account and migrate to it...windows.microsoft.com/en-US/Windows7/… –  Moab Nov 22 '11 at 21:00
    
I tried Windows Update with a newly created account and it failed with the same error code. –  StickFigs Nov 23 '11 at 6:17

3 Answers 3

EDIT: Check your system time to be sure it is correct.

Copy the text below into a text file, then save it as a .bat file and execute it, this will reset Windows Update. Be sure the text below is in a text file as separate lines as shown.

When done run a manual Windows Update, it may take some time to list the updates because it has to rebuild the Softwaredistribution files.

net stop wuauserv

rmdir %windir%\softwaredistribution /s /q

rmdir %windir%\system32\softwaredistribution /s /q

regsvr32 /s wuaueng.dll

regsvr32 /s wuaueng1.dll

regsvr32 /s atl.dll

regsvr32 /s wups.dll

regsvr32 /s wups2.dll

regsvr32 /s wuweb.dll

regsvr32 /s wucltui.dll

net start wuauserv

.

EDIT: This is the short version of the reset procedure, but should fix your Softwaredistribution folder corruption, the Full reset Fixit and manual fix it myself instructions can be found here.

EDIT:If for some reason deleting the Softwaredistribution folder fails, boot from a linux cd and delete it from there.

.

share|improve this answer
    
There is a lot more to resetting the Windows Update components. See support.microsoft.com/kb/971058. There is a Fix-It there also. –  Patrick S. Nov 22 '11 at 23:15
    
Thanks Patrick, Mine is the short version which will fix the OP's softwaredistruibution folder corruption. –  Moab Nov 22 '11 at 23:43
    
I've already tried this fix before, also while running the .bat it said this: rmdir C:\Windows\system32\softwaredistribution /s /q The system cannot find the file specified. –  StickFigs Nov 22 '11 at 23:43
    
Manually navigate to that folder in explorer, is it there? You may have to unhide system and hidden folders to see it. Also check my edit at the bottom of my answer. –  Moab Nov 23 '11 at 0:35
    
It's not there because I already tried deleting it before. –  StickFigs Nov 23 '11 at 6:09

I created & ran the .bat file per the blog entry above. I copied the softwareDistribution folder (Windows folder) from a PC where updates were working to the Windows folder on the problematic PC.

This resolved the problem.

share|improve this answer

First of all try to repair system files..

Click the Start Orb & type cmd.exe into the search menu.

Right click it & run as Administrator.

Type the following command: sfc /scannow & hit enter.

Wait for the process to finish, when it's done. Reboot the system.

then try again.. if it does not work then use microsoft fixit tool.

there may be some other issue so follow these links for more information.

http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_update/windows-update-problem-80096001-error-code/e7110943-588d-4b07-84c7-ce7416fb999b?tab=MoreHelp

http://social.microsoft.com/Forums/el-GR/genuinewindows7/thread/20d5ef9d-acf8-4efb-b748-e451048629a6

if all fail then go to Microsoft online update website.. use this it works mostly for me when auto update give error in updating windows for me..

share|improve this answer
    
I have already tried sfc /scannow several times already, what happens is that at the end the window says that it found problems but couldn't fix them. However when I look at the CSP.log file there are no reports of any problems which is strange. Also already tried Microsoft Fix-It tool and it scanned and didn't find any problems. I have also already tried MicrosoftFixit50202.exe and MicrosoftFixit50528.exe and neither worked. –  StickFigs Nov 22 '11 at 14:26
    
See this article, there are manual solutions besides the fixit....support.microsoft.com/kb/822798 –  Moab Nov 22 '11 at 16:46
    
Free Windows Update support from Microsoft..support.microsoft.com/oas/… –  Moab Nov 22 '11 at 16:48
    
have you tried to install updates online from Microsoft website?? –  Niranjan Kala Nov 22 '11 at 17:02
    
@Moab I've already done all of the fixes including the manual fixes, none helped. I have already started a support ticket with Microsoft but they didn't help and tried to pawn me off on to the MSE support folks for some reason. NiranjanKala: Whenever I try to install any sort of Windows updates I get the 0x80096001 error and it fails. –  StickFigs Nov 22 '11 at 19:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.