Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 7.

I plug in a USB stick containing MP3 files

I open Windows Media Player and select the drive letter of my USB stick, I then see all my music nicely grouped into artist and album just like the MP3 files on my hard drive.

I right-click on an album, hmmm... no 'Play' option - just 'Add to sync list' and 'Delete'.

OK, so I'll try just playing one trac, so I right click a single track - again there is no 'Play' option just 'Add to sync list, 'Delete' and 'Properties'.

So I try double-clicking a track, nothing happens

I can't even create a playlist by dragging the files onto the 'Drag items here' playlist pane.

If I access MP3 file that are on my hard drive then it all behaves as expected - I get a 'Play' option when right clicking an album or a track.

If I open the USB drive in Windows Explorer and double click a track then it plays.

What's going on?

I am at work so could there be a policy that is preventing me doing this?

share|improve this question
If you go into the "synch" tab and follow the instructions here:… but instead, choose the device and then choose "End synch partnership", that worked for me! – Andrew Johnson Dec 27 '13 at 0:20

5 Answers 5

up vote 2 down vote accepted

It seems that this is actually the normal behaviour. USB memory sticks show up in Windows Media player but only for syncing files - there is no play option. The only way I could find of opening the files is to use File -> Open... from the main menu. It is possible to open several files at once by dragging a selection rectangle over them.

I used to use Media Player to play from my external hard drive by setting it as a library location but this isn't allowed with most memory sticks as they Media Player detects that they are removable devices.

If you have a spare external hard drive then you could try using that instead and add it to Windows Media Player's library locations. To do this, right-click Music in the left-hand pane, then choose Manage Music library and click the Add... button.

Unless you are really set on using Windows Media Player, my advice is to download foobar2000 and install it on to the memory stick in portable mode - suitable for use at work as no files need to be installed on the host computer. Using Library -> Configure you can tell it to look at a folder on the drive that contains music, and any new files get indexed automatically.

share|improve this answer
Thanks for your answer, at least I know I'm not losing my mind. I do find it totally baffling behaviour though. Thanks also for pointing out foobar2000 although I have now installed good old WinAmp and it plays the files straight from the USB stick. – ChrisB Nov 23 '11 at 15:11

For Windows 7/WMP 11, I found an easy workaround.

  1. On your USB memory stick, right-click on the music folder you'd like WMP to play songs from. Choose 'Create Shortcut'.

  2. In your computer's Music folder in Libraries, paste the Shortcut that is linking to the music folder on the USB drive.

  3. In WMP, click on Music in the table of contents on the left-hand side of the window. The songs from your USB stick should now appear in the list of music to be played.

share|improve this answer

The suggestion to share the USB drive works. This is how I did it on Win7:

In a file explorer window, I right click on the drive, select "share with" and then "advanced sharing" (which is the only option I see). This brings up a popup with tab "sharing" showing a button "Advanced Sharing". I click on that, which brings up another popup that has a checkbox to "Share this folder". I click that to put a checkmark in it and hit OK.

In the window beneath, I see the icon for my flash drive, its drive letter, and below, its Network Path (for me, "\mymachinename\d", as my flash drive's letter is "D".) I copy this text.

In WiMP's navigation pane, I right click on Music and select "Manage Music Library". I click the "Add" button and paste in the copied text. Bingo, my flash drive's music appears in my WiMP library!

BTW, I had this problem on a previous Win7 computer and got around it without using network sharing. I don't remember how; I suspect it was a shortcut, but that doesn't work.

Very annoying that MS doesn't think we should use removable drives to hold music.

share|improve this answer

I found that using the properties of the usb drive to turn on sharing and set access only to myself, works great. I can still unplug and plug my usb drive and it will still be shared.

share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – slm Apr 16 '13 at 17:00

Easy work around: (I use a large list with all files on shuffle, this should also work for individual playlists)

1.Navigate to your USB drive and find the folders you want
2. Select the relevant music files you want to play
3a. Right click on the selection and select Play (for individual albums)
3b. Right click on the selection and select Add to WMPlayer Playlist (for adding all songs to one large list)

If you follow step 3a you can then save individual playlists of each album/sets of music files.

share|improve this answer
Welcome to Super User! Please read the question again carefully. Your answer does not answer the original question. OP has already said he doesn't have a play option on right click. – DavidPostill Mar 20 at 15:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.