Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Laptop with i7 (4 cores), 8GB ram and SSD OCZ Vertex 3 MaxIOPS which in testing that I did just now does 400mb/s+ read/write. However the responsiveness of Windows Explorer is far from being perfect. Opening up Computer, Documents, going into folders is very slow (1-5seconds).

I don't have any viruses or spyware and I have tried changing properties to optimize view for General Items. I tried disabling Search Indexer but it made search in Outlook 2010 crawl and didn't bring any other effect. Even double clicking on file takes some time to open things up (like clicking a Word document).

I don't have any drives mapped, my computer is not joined to domain. I have multiple VPN connections that I connect to but they all have disabled default gateways. I tried using CC Cleaner or some Windows 7 Tweaks app to disable some things.

I am power user using Visual Studio, Tortoise SVN and other developer/administration apps. Any non obvious ideas?

Edit: So I've been trying to pinpoint where the issue comes from and it seems that straight after reboot Windows Explorer opens very fast, when I load 3-4 programs (Royal TS, Visual Studio, Outlook) it's noticeably slower and the more programs I have it gets worse. After I start closing programs it starts working better and if I leave 2 open it's fast again. I tried doing some research with DiskMon and other programs from sysinternals but couldn't find anything suspicious.

Below are stats during normal usage with a lots of programs open:

- Ram usage with a lot of programs open and no swap file (i disabled it for testing): 6.95GB 
- CPU usage: 15%, none of the cores takes more then 50% (I have VS 2010 open x 4)

HD Tune Pro: OCZ-VERTEX3 MI           Benchmark  

Test capacity: full  

Read transfer rate  
Transfer Rate Minimum : 363.9 MB/s  
Transfer Rate Maximum : 505.5 MB/s  
Transfer Rate Average :   
Access Time           :   
Burst Rate            :   
CPU Usage             :   



HD Tune Pro: OCZ-VERTEX3 MI           File Benchmark

Drive C:

Transfer rate test

File Size: 500 MB

Sequential read 484102 KB/s
Sequential write    444714 KB/s
Random read 7779 IOPS
Random write    16888 IOPS
Random read (queue depth = 32)  73007 IOPS
Random write (queue depth = 32) 69790 IOPS



HD Tune Pro: OCZ-VERTEX3 MI           Random Access

Test capacity: full

Read test

Transfer size   operations / sec    avg. access time    max. access time    avg. speed
512 bytes   3260 IOPS   0.306 ms    2.106 ms    1.592 MB/s
4 KB    4161 IOPS   0.240 ms    2.006 ms    16.256 MB/s
64 KB   2382 IOPS   0.419 ms    2.367 ms    148.934 MB/s
1 MB    449 IOPS    2.225 ms    4.197 ms    449.407 MB/s
Random  809 IOPS    1.235 ms    6.551 ms    410.527 MB/s


HD Tune Pro: OCZ-VERTEX3 MI           Extra Tests

Test capacity: full

Random seek 3975 IOPS   0.252 ms    1.941 MB/s
Random seek 4 KB    4245 IOPS   0.236 ms    16.583 MB/s
Butterfly seek  4086 IOPS   0.245 ms    1.995 MB/s
Random seek / size 64 KB    3812 IOPS   0.262 ms    58.606 MB/s
Random seek / size 8 MB 120 IOPS    8.348 ms    485.737 MB/s
Sequential outer    4524 IOPS   0.221 ms    282.721 MB/s
Sequential middle   4429 IOPS   0.226 ms    276.818 MB/s
Sequential inner    5504 IOPS   0.182 ms    344.000 MB/s
Burst rate  4472 IOPS   0.224 ms    279.475 MB/s
share|improve this question
    
Search indexer or something else (anti-virus scan/update) running and using alot of CPU time/disk access? –  HaydnWVN Nov 22 '11 at 12:32
    
CPU usage (5%), memory usage (2.29gb) and hdd is all fine. I can now run SSD Test with HD Tune and it shows 400mb in/out so it's clearly not an issue. I don't have antivirus. –  MadBoy Nov 22 '11 at 12:36
1  
My pagefile is 8gb currently managed by system. From 16mb minimum to 12gb max. 88gb free space on SSD. –  MadBoy Nov 22 '11 at 12:45
1  
After reboot it started working fine. Very fast and dandy (so some fixes I applied seems to taken action). However I am now like 10-15 minutes after reboot and it does feel a bit slower then from start. Will see how long it goes like this. –  MadBoy Nov 22 '11 at 13:11
1  
Try the various SysInternals utilities to see what is going on during this slow down. Can start with Process Monitor technet.microsoft.com/en-gb/sysinternals/bb896645 –  Brian Nov 23 '11 at 7:11
show 10 more comments

1 Answer

up vote 0 down vote accepted

I've disabled C-States in BIOS and computer is much faster now in terms of Windows Explorer responsiveness with more programs running. I'll try to play with it a bit more but it seems like it solves most issues. I will try to play with other performance/power management features of processor in bios.

share|improve this answer
    
Check your power management settings in windows to ensure that the maximum processor percentage is 100% under load. Also, make sure your BIOS is updated. –  Bigbio2002 Nov 24 '11 at 23:48
    
@BigBio2002 Bios is updated and, 100% cpu is set for min and max while connected to power. –  MadBoy Nov 25 '11 at 10:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.