Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Viewing messages in mutt are colorized, but piping them through the less pager removes colorization. How do I preserve message colorization?

I've tried: | less -R

but colorization is stripped prior to less input.

share|improve this question
    
less or the pipe probably didn't remove your coloring. It's possible the matt program is detecting where its output is connected to and when it's not a color terminal, it disables color formatting. You need to find the option that overrides this behavior. – billc.cn Nov 22 '11 at 22:57
    
@billc.cn: Yes, that is my point, though I should have clarified it better. I'd like to know if there's a mutt option for output without disabling color ANSI sequences (before I hack through the source code to investigate). – Jeff Bauer Nov 25 '11 at 15:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.