Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

First I have a cable modem which gives the internet connection. The network is 192.168.0.0/24 and its IP is 192.168.0.1

Second line, I have a router connected to the cable modem. Its "outside" IP is 192.168.0.12. This router creates network 192.168.123.0/24 and its IP there is 192.168.123.254.

My computer is wired to the router with IP 192.168.123.126.

At this point I am able to access both devices web interfaces by their IPs on a browser (192.168.123.254 for the router and 192.168.0.1 for the cable modem).

The problem I have is when I connect to a VPN from the computer. Then I am connected to a second network 10.0.0.0/24 and I get IP 10.0.0.200 (along with 192.168.123.126). I can connect to the router but then I loose connectivity to the cable modem: I cannot acces it through the browser, neither making a ping to it or a tracert.

I have tried to add a new route to the windows routes by typing

route ADD 192.168.0.1 MASK 255.255.255.0 192.168.123.254

But I cannot seem to access it this way.

Am I missing something on the route adding? Which is the proper way of doing this? Thanks

share|improve this question
    
Why are you using 2 "routers" and not simply using either a switch or making the second router into a switch? – MrStatic Nov 22 '11 at 17:02
    
Your route command has an inconsistent network address and mask. If the mask is 255.255.255.0, the network address would be 192.168.0.0. Otherwise, you'll get a 'The parameter is incorrect' error. (A network route needs a network address.) – David Schwartz Nov 22 '11 at 17:45
    
@MrStatic, it is what I have at home... the cable modem only has one output and I need more than one, so I plug in the router there so I get more outputs. I do not know how to convert router into switch either – spuas Nov 22 '11 at 20:48
    
@DavidSchwartz, thanks that worked out! I though I should place there the IP I wanted to reach and not the complete network Thanks! (I cannot give it as right or solve the question since it is a comment) – spuas Nov 22 '11 at 20:51
up vote 0 down vote accepted

Your route command has an inconsistent network address and mask. If the mask is 255.255.255.0, the network address would be 192.168.0.0. Otherwise, you'll get a 'The parameter is incorrect' error. (A network route needs a network address.)

thanks that worked out! I though I should place there the IP I wanted to reach and not the complete network

You can do it either way, you just have to be consistent. You've tried to place a network route to a host.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .