Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I was trying to set up a VPN connect on my laptop running Windows 7 Ultimate, I got this error:

Network Connections

Cannot load the Remote Access Connection Manager service.

Error 711: The operation could not finish because it could not start the Remote Access Connection Manager service in time. Please try the operation again.

I traced through some service dependencies and discovered that Secure Socket Tunneling Protocol Service was set to Manual. However, when I try to manually start the service, I get:

Services

The Secure Socket Tunneling Protocol Service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.

Setting all the services involved to Automatic did not help. SSTP just showed Automatic and Stopped in the Services panel.

I found a solution that involved booting in Safe Mode and deleting the contents of C:\Windows\System32\LogFiles\WMI\RtBackup. This solution worked, and I could set up a vpn connection, but only until I rebooted again.

TL;DR I'm looking for a way to permanently enable Secure Socket Tunneling Protocol Service and other vpn-related services permanently so I don't have to reboot into safe mode and delete files every time I need to connect to a vpn.

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

Although it is not listed as a dependency, the reason SSTP isn't working is caused by Event Viewer not running, usually because of a problem with one or more of the event logs. Deleting the files in \RtBackup permits the Event Viewer to run, which allows SSTP to start, but when you reboot the issue recurs, as \RtBackup is recreated.

If after removing the \RtBackup files you clear the various logs from the Event Viewer (after saving a back up, of course), this will remedy the issue preventing the Event Viewer from loading. This should permanently fix the issue with SSTP not starting.

share|improve this answer
add comment

If you're unable to change the name of RtBackup, remove the files from it and then change the name of the folder and copy the old files to the new folder.

share|improve this answer
add comment

you can solve all the problems with services by simply restoring them to default. you can do this with a registry file, just carefully choose your version of Windows from the list provided at BlackViper.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.