Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've encrypted my system partition using TrueCrypt and I've read that I can mount my encrypted data partition (TrueCrypt volume) on boot by making it a "System Favorite" and giving it the same password as the system partition. However it doesn't work and I have to mount it manually every time.

See this example.

I've tried enabling "Cache pre-boot authentication password in driver memory (for mounting of non-system volumes)" in System -> Settings, but that didn't change anything either.

Any ideas?

share|improve this question
    
FYI, I'm currently struggling with exactly the same issue. At some point I got it working but it ignored the assigned drive letters; now it's broken again. –  Christoph Rüegg Nov 23 '11 at 18:50

2 Answers 2

up vote 2 down vote accepted

Take care, that you use a english keyboard-Layout when setting the passwort for the volume. (because the pre-boot-auth-password will be typed with english keybord)

share|improve this answer
    
How does this solve it not mounting? –  Simon Sheehan Nov 29 '11 at 23:27

In my Windows 8 I need to reboot my computer before system favorites mount.

At the first boot, the system favorites are not mounting, but on reboot do. It is very strange and I assume it is some kind of bug in Truecrypt 7a.

I guess I could take all my system favorites and convert them to normal favorites; then I can manually mount them after booting. But since some start-up programs already created some havoc by then, I always go the reboot route. So type in your password on boot, after loading select restart, type in your password again and then everything works as it should.

It's a nuisance, obviously, but it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.