Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Microsoft SQL Server Management Studio 2008 R2, I followed the instructions from my host and I'm successfully able to connect to my database, but I also happen to see all of the databases on the host (which is really annoying because there are a lot of them)! Note that I set the options in the "Connect to Server" window to connect to my database, but it still shows me all of the databases on the server.

Is there away to avoid that?

share|improve this question

1 Answer 1

This is the default behavior of SSMS. You will need to limit your user's permissions to hide the databases you don't want to see.

However, you should not normally do this to your Windows mapped user or any administrative account. You may want to create a new SQL user (if you use mixed accounts) or a new Windows user (use the "Run as a different user" feature to open SSMS).

share|improve this answer
    
Thanks... helpful info, however I think I've done those things already, because I'm specifying the SQL user that I created when I created my database in my host's control panel. –  Lirik Nov 22 '11 at 23:05
    
@Lirik: Did you create a separate User role or assign them an existing one? What were the permissions you assigned for the security objects if you created your custom role? It will be difficult to troubleshoot considering you only "think [you've] done those things already." We need to know for sure what you know you did. –  surfasb Nov 23 '11 at 4:33
    
@surfasb I didn't modify/specify a user role. I'm using whatever the default user role is... however, I was thinking that there might be an easy answer to this: like some kind of an option while connecting. Are there any specific settings that control which databases I see on the server? –  Lirik Nov 23 '11 at 5:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.