Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lenovo Thinkpad T420. I use it in three situations:

  1. Connected to docking station with two LCD monitors at 1280 x 1024.
  2. Connected to docking station with two 21" LCD monitors at 1680 x 1050
  3. In regular laptop mode (using the native monitor).

In all three situations, my screen resolution gets adjusted automatically, and the monitors (or monitor) appear as they should.

The problem is that, in the first situation, the desktop gets extended to a third monitor (VGA) even though no monitor is plugged into that video card. I have to manually turn off "Extend desktop to this display" or my cursor gets lost in this region of my desktop.

Is there any way to prevent this from happening? It never happened until I moved my workstation from one part of the room to another, which involved unplugging everything and re-plugging it back in.

Settings on startup

enter image description here

Settings after turning off "Extend destop to this monitor"

Why won't it remember this?

enter image description here


EDIT

Screen capture of my display settings for situation #2:

Monitor #1 and #2 are reversed. Could this be the reason for the problem?

enter image description here

share|improve this question
    
Probably because Windows is just reporting what the hardware is telling it. It has no idea that's the two docking stations are different. Nor should it really concern itself.If the docking stations are that different, then the hardware needs to report so, otherwise there really isn't any way for the OS to see "past" what the hardware reports. –  surfasb Nov 23 '11 at 11:22
    
@surfasb, thanks for your comment, but there are a couple things I want to point out: (1) The two docking stations are exactly the same...the only difference is that I have slightly larger monitors plugged in to one of them, (2) The problem wasn't happening before I unplugged/replugged my monitors when I relocated my workstation. –  devuxer Nov 23 '11 at 18:24

4 Answers 4

As far as I am aware, there's no way to force Windows 7 to not use settings it autodetects from the graphics hardware. This is fundamentally the same problem as How to disable monitor auto detection in Windows 7? -- it appears Windows thinks what the hardware says is more important than what the user says.

In some ways, this is better than how things were done in previous versions of Windows -- namely, because plugging a Win7 machine into, for example, a projector works as a user would probably expect in all cases. That is, the projector is initialized and treated as a screen without digging through the control panel.

Unfortunately, such things do result in cases where the auto detection goes wrong, but Windows doesn't seem to provide any sort of override switch for this, which is unfortunate.

Something seems to be making the graphics there believe a third display is connected; you may wish to see if blowing the connectors out with gas duster has any effect, both on the actual VGA connector and on the dock connector (male and female sides for both connectors).

One last thing, for your Lenovo specifically, the most recent Intel HD3000 driver updates available on their website have this in the changelog (emphasis mine):

CHANGES IN THIS RELEASE Version 6.14.10.5384

[Important updates] Nothing.

[New functions or enhancements] Nothing.

[Problem fixes]

  • Fixed an issue where a video embedded into a PowerPoint document might not play or the system might crash during playback.

  • Fixed an issue where no video is fed to the external monitors when the user locks the desktop before docking the system.

This isn't exactly your issue but installing the update may help anyway. If you have a discrete graphics card in your particular configuration, also check to see if an update for that is available (my machine is an X220 so I'm not familiar with the discrete graphics options available on the T420...).

share|improve this answer
    
Billy, thanks and +1. I will update my graphics card drivers and see if that helps. I may not get to trying this right away, but I'll definitely come back and mark your answer if it works. –  devuxer Nov 23 '11 at 21:48
    
Billy, finally got around to updating my Nvidia driver and Lenovo tools, but, unfortunately, it didn't solve my problem. –  devuxer Dec 24 '11 at 21:05
    
+1, I updated my graphics card drivers to fix this issue. –  pqn Jun 17 at 6:06

I had a similar problem where I used different external screens/projectors and couldn't get my display at home to work since Win 7 recognized the display as the big plasma I had used earlier.

It would really seem that there is no internal solution within Windows 7 which is quite retarded. However, check if there is any sort of override key combination for your graphics card.

I use an internal Intel chip with my laptop, and it overrided the automatically recognized screen settings by pressing Ctrl+Alt+F3. After that I got my laptop screen to show the desktop and from there I could set the settings for the external display.

No clue if this helps, but thought I'd share.

share|improve this answer

I wrote a script that sets the resolution to what you want when you run it using ResSwitch. It's not a good solution, but it's better then nothing. You may need to edit the script if you have multiple monitors.

  • Run FixResolution.vbs to set your resolution to 1280*1024 silently.
  • Edit SetResolution.bat to change the resolution you want.
share|improve this answer

I had this problem and it was because NVidia ignored windows settings. Once I always used nvidia panel to adjust my setup I've never had a problem. Nvidia also remembers different setups for those rare occasions when you dont connect all your monitors.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.