Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an XP machine with 3 Hard drives (320GB, 320GB, 80GB). Each has 1 partition and is NTFS and SATA. After windows loads I can open Windows Explorer, and it appears immediately. However, if I click on 'My Computer' it spends about a minute 'looking' for the hard drives with its animated flashlight icon. During this time, major applications, like Chrome, won't load up, so it sounds like the problem is not limited to explorer. Once they have appeared, everything works normally and without delay.

Is there some way to shorten the time taken to find the drives?

share|improve this question

1 Answer 1

Do you have any mapped network drives? Explorer will attempt to enumerate ALL drives before presenting them (was solved in Windows 7), so if you're on a network, it may take several seconds.

Also check to see whether you have installed any programs that manifest as Explorer plugins. There are several such applications, but 2 come to mind in the context of slowing down Explorer: TortoiseSVN (not relevant if you're not a developer and you don't use SVN) and an extension, whose name escapes me right now, that calculates folder sizes (basically it adds a column in Explorer showing size next to folders - but it takes a while to calculate the number).

share|improve this answer
    
Yes, I use Tortoise. However, applications also won't load during the delay, so it sounds like the problem is not limited to explorer. –  Rocketmagnet Nov 23 '11 at 11:01
1  
Are all HDs internal? Because it may be a fault HD enclosure, a faulty USB plug or some screwed up driver... –  Traveling Tech Guy Nov 23 '11 at 11:03
    
Yes, all internal. However, there is also a USB FLASH card reader installed in one of the 3.5" bays. There are no cards in it at the moment though. –  Rocketmagnet Nov 23 '11 at 11:06
    
Any delays in your POST? Thinking along the lines how older hard drives set to 'Auto' in a BIOS could really delay the POST but when manually specifying the settings (ie no Auto) POST was quicker... –  HaydnWVN Nov 23 '11 at 11:07
    
Unplug the flash reader! Have problems with them here delaying network access and sometimes even being 'autodetected' (for no reason) and being allocated mapped drive letters - which i'd previously changed the flash drive from in disk management :) –  HaydnWVN Nov 23 '11 at 11:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.