Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After 15 minutes, my display correctly goes to screensaver mode (Photos, Wait: 15min, "On resume, display logon screen"). If I press a key or move the mouse, the screensaver correctly halts and I get the login screen to enter my password.

However, it doesn't always work. Last night, for example, I turned my monitor off (power button), and when I woke up and turned it on, the screensaver hadn't kicked in.

Power Plan is High Performance, monitor-off is "Never", sleep is "Never".

Without changing any settings, my screensaver kicks in sometimes and not others. Overnight it hasn't been turning on lately, but when I went out for dinner it was on when I came back. It's really starting to baffle me.

Update: The screensaver seems to not activate correctly more often when I have updates waiting to be installed (I hate rebooting).

share|improve this question
add comment

5 Answers

I just experienced a similar problem with my Logitech VX Nano wireless mouse. Up until recently I used it with an XP machine, without any problems. I got a new laptop with Windows 7, and moved my mouse to it. After a while the screensaver stopped working. After some research (including reading this question and previous answers) I understood it's the mouse. Originally, I didn't install the Logitech software (SetPoint). I now installed it (I downloaded the newest version), and my screensaver started working again. It seems that the device drivers that come with Windows 7 don't handle it very well and it seems to the system that the mouse is sending some movements to the computer.

share|improve this answer
add comment

What kind of mouse do you have? Some older mice incorrectly register movement on certain surfaces like wood or glass, automatically interrupting the screensaver. In addition, Vista and Windows 7 have a feature where Windows automatically increases the delay if the screensaver is interrupted shortly after activating. If the mouse has indeed been interrupting the screensaver for the whole night, the screensaver might not activate even if you wait for those 15 minutes.

Try unplugging your mouse for one night and see whether the screensaver has activated in the morning.

share|improve this answer
1  
A wired, optical Intellimouse Explorer with a mousepad, both of which I've been using forever and had no screensaver problems in Vista.. I guess it can't hurt to give it a try. –  Andrew Coleson Oct 13 '09 at 15:39
add comment

This might be because of some program that you have/had running at the moment you turned off the monitor.

Some programs are programmed on purpose to disable the activation of the screen saver.
For example, a program that does media playback may do this to avoid disruption when watching the movie.

share|improve this answer
1  
That's what I was thinking, but I'm not running anything media-related.. –  Andrew Coleson Oct 13 '09 at 15:37
    
If this occurs again, try to find some connection to what you did before. –  harrymc Oct 13 '09 at 16:17
add comment

I had this happen with Windows XP for quite a while, and the solution turned out to be quite bizarre:

The screen saver does not start after you install a wireless pointing device

The solution in my case was to download a (free) updated version of PowerDVD, which solved the problem.

So you might look for similar incompatibilities in your case.

share|improve this answer
    
Hmm, interesting info, but I'm not sure I have anything like that. I'm not using anything wireless, and I only have WMP installed for DVD playback. On the other hand, it used to usually work and now seems to never be working, so I must've installed something recently that's blocking it.. –  Andrew Coleson Sep 9 '09 at 18:13
add comment

Side topic: I had a similar issue arise when I used the beta build 7k, but didn't involve turning off the monitor.

I think my steps were let it go to screen saver screen lock. Then prompt to change user, then cancel and then the screen saver screen lock went away. The only way to then lock the machine with that user is to restart. Even logging out and locking didn't fix it.

Being diligent, I wrote up a nice little message to the Softies for them to fix it.

My answer:

Based on an XP system, you should be getting the login screen in both cases. But being Win 7, if I remember correctly (as I'm not currently running it) there's a setting that states something to the effect of "lock screen on awake" in the power settings. Perhaps your screen saver is set to lock and this other setting is not.

share|improve this answer
    
In my Advanced power settings, "Require a password on wakeup" is set.. I'm going to try disabling the automatic display-off and see if that works around it. –  Andrew Coleson Sep 5 '09 at 2:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.