Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can no longer git svn rebase (using msysgit on Windows 7).

The error starts with:

Byte order is not compatible at ../../lib/Storable.pm

And ends with:

Could not unmemoize function 'lookup_svn_merge', because it was not memoized to begin with

It may be overkill, but I've tried reinstalling the fule Git Extensions package with msysgit. I also made sure that cygwin git and/or perl aren't interfering. I seem to be stuck rebasing consistently on this one commit; before this, it was fine. A colleague who uses git-svn on Windows against the same subversion repository had no problems, so it's something specific to my development machine.

share|improve this question
    
There's a similar Perl cache related bug recently submitted to git-svn, which they patched. Perhaps Google hasn't applied the same fix to msysgit (yet?). – Ƭᴇcʜιᴇ007 Nov 23 '11 at 20:48
up vote 5 down vote accepted

I have no explanation for why this worked, but deleting .git/svn/.caches/ fixed the problem. I guess the error message was referring to the lookup_svn_merge.db that's stored in that folder?

share|improve this answer

This is happening because of an incompatibility in data files created by Perl's Memoize::Storable across different versions of Perl.

It is safe to remove .git/svn/.caches to fix the problem.

More information can be found about the bug in Debian and the discussion of the fix.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .