Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Please read the whole thing before commenting if you would really like to help ! :)

I've had this problem for a very long time now and tried MANY different solution.

Here's the problem. My desktop computer is linked to my WiFi via a USB D-Link wireless adapter. It works fine, until I try to download large files via torrent, or simply download a lot, it crashes. My connection is lost.

Most of the time, I can just unplug it and plug it back in to make it work again. But sometimes, when I unplug and plug it back it my computer makes an unusual USB sound. It is pretty hard to describe a sound via words, but I think you know what I mean. Instead of doing the regular "tu-du" new device connected sounds, it makes this "tu-du-du" bad usb sound and I have to restart my computer to make it work again and it is extremely annoying.

So... here is what I have tried so far.

  • Updating the adapter firmware
  • Plug it in every available USB ports on my computer
  • Ran a certain command line someone suggested that I cannot remember.

Recently tho, someone suggested to me a solution that makes a lot of sense. To go in device manager, and uncheck "Allow Windows to disable the device to save power" under the power management tab of the adapter itself.

I was very exited about this solution, only to arrive at home and find the "Power Management" tab is missing under my device and many others.

So yeah, this is everything I tried so far. I am all out of ideas. And before you ask, the reason my computer isn't directly plugged to the internet is a long story and even tho I know it is the best solution it is not possible in my current situation.

I am running Windows Vista (SP1).

Edit: To be more specific, what I really seems to be happening is that thing where "Windows shuts down the adapter to save power" because let's say I'm downloading at 1.8mb/s, the speed will gradually go down until it reaches 0 and the adapter dies. It's really like windows kills the adapter and won't allow it to work until I restart. Unfortunately, the Power Management tab is not there for a reason I don't understand.

So thank you so much for reading me and I can't wait for your suggestions.

share|improve this question
2  
What is the router you're connecting to? I've seen bad firmware on either side cause this - if it's an old router you might find that simply flashing the firmware will fix it. – Shinrai Nov 23 '11 at 20:08
1  
Try a different wireless network, try a different wireless network adapter. Try the adapter on a different computer. – Ƭᴇcʜιᴇ007 Nov 23 '11 at 20:21
2  
In addition to firmware for the router, make sure you have the latest drivers for the USB WiFi card, and make sure you've got the most recent Windows updates. – music2myear Nov 23 '11 at 20:21
1  
Yes, "flashing the firmware" = updating. – Shinrai Nov 23 '11 at 20:26
1  
Is the adapter getting warm? The wireless chipset could be overheating as there is very little air flow in the USB key WIFI adapters. – Lamar B Nov 23 '11 at 20:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.