Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a bit of a problem that I need solved, and it's been bugging me for days now.

I have two computers:

Computer A

- Windows7 with a :
- CellC 3G Huawei modem - IP is dynamic with each connection.
- NetGear wireless card - IP = 10.0.0.102 (Default Gateway: 10.0.0.2)

Computer B

-iMac running Snow Leopard
-Connecting via Airport - IP = 10.0.0.101 (Router IP is: 10.0.0.2)

Wireless Billion 400G Router

- No internet / DSL connection on this one.

The two machines are connected via the wireless router, and I am able to ping both ways, I can ping 10.0.0.101 from the Windows machine and 10.0.0.102 from the iMac.

Computer A has internet access, but when I fire up my browser on the iMac, there's simply no internet connectivity, no matter what I try.

I have shared the CellC modem for ICS (Internet Connection Sharing), I also tried sharing ICS on the Wireless adapter on the Windows machine.

Is it possibly because the 3G model has a dynamic IP, and it's sitting on a different subnet mask?

Can anyone please help?

share|improve this question
add comment

2 Answers

As the wireless router is not there to provide any routing, it doesn't have a WAN connection of its own so it is is just acting as a switch. It shouldn't be a default gateway for any device because it isn't a gateway.

What you need to do is enabled ICS on the laptop interface that leads to the internet - the 3G modem, and choose the wireless card as the private network.

This should then reconfigure the IP address of the wireless card with a 192.168.x.x address. It will also turn your machine into a DHCP server, so that other devices on your network can obtain an IP address in the 192.168 range, and will have their default gateway as the 192.168.x.x address assigned to the wireless card.

The reason this is not working now is that the default gateway of the MAC is the wifi router, which doesn't have a path to the internet. You need to disable DHCP on the wifi router in order for the MAC to get a 192.168 address from ICS on the laptop.

share|improve this answer
    
Tried this and managed to get the two machines seeing each other. I was able to ping them, but after a restart, I keep on getting "Request timed out!" I turned off DCHP on the router, and set the machines to 192.168.0.1 and 192.168.0.2 respectively, also tried DHCP and "DHCP With Manual Address" on the Mac. Nothing want's to work. :( –  josef.van.niekerk Nov 24 '11 at 8:24
    
I'm now able to ping both ways again...but no internet connection. –  josef.van.niekerk Nov 24 '11 at 8:29
    
Do not set the IP addresses of either machines wireless connection. Let Windows look after the PC and set the mac to straight DHCP. On the mac, check the IP details it was given and confirm that its default gateway is the same IP address as the PC's wireless card. –  Paul Nov 24 '11 at 8:35
add comment
up vote 0 down vote accepted

Managed to fix my problem buy getting a 3G router and connecting via the 3G. No more internet problems.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.